Warsmith journey will not complete in age of war

follow the warsmith journey step, find the final step to complete the journeystep:

  • wear a piece of epic armor

equip several piece of epic armor, nothing happens, you are stuck and cannot complete the journeystep

I’ve seen where a few journey steps won’t complete unless you die and then respawn.

I’m having the same problem. Haven’t died yet.

I died many time since, seem to not be a solution in this case.

For interest, was the epic armour crafted or found?
I found amny of the journey steps needed crafting or even recrafting before hte journey system acknowledged the item/completion.

crafted, tried several model, light, heavy etc

And i confirm that a found epic armor do not solve the problem neither; stuck.

Greetings Exile,

Our team requested a bit more information to be able to reproduce the issue correctly.

  1. Could you please provide us with a screenshot of your current progress on the Warmaker Journey?
  2. As well as a list of armor pieces you tried on (if you still remember some).
  3. And a video of you crafting a piece of epic armor and equipping it right after being done?

Thank you in advance.


tested to wear crafted any piece of those (garrison armorer bench with silas the weathered armorer thrall)

ranger armor epic
champion epic
khari raider epic
khari oversee epic
godbreaker epic
kurak epic
rdeemed epic
voidforged dragonhide epic

and a dropped from chest cimmerian pant epic

when i reached this step of wasmith i was already wearing an epic armor on my character.

Its on online beta publicservertest europe exile lands


Same hear. Cant complete it no matter what armorni try.

Are you using mods ? I was unable to validate the Archer journey step 'craft iron arrow" while i had the mod Better Archery (or a name like that) in my mod list. I removed it and the step validated. It was not in the bet, though.

Its online beta official server, so no mod

1 Like

Having the same issue with both Warsmith and Master Armorer journeys.

Like the OP I was already wearing a couple of pieces of crafted Epic armor when I tried to complete these journey steps.

Tried crafting and wearing epic armor pieces from the Silent Legion and Redeemed Legion sets on both a Garrison armorers bench and an Improved armorers bench.

No mods - on a private test server.

1 Like

Having the same issue here with both Warsmith and Master Armorer at the same stage.


  1. Like Shazroth, I was already wearing some epic armor when I had the journey active.

  2. Both are stuck at the last step.

  3. In the description for “wear a piece of epic armor” step in Master Armorer, the text says "craft an Epic Armor in the crafting panel of an Armorer’s Bench;

  4. and the previous step for “Craft an piece of Epic Armor” the text says to “unlock an Epic Armor from the knowledge menu”.

  5. Both of these steps in Warsmith seem identical but lack the description in the journey steps text information.

  6. Also tried adding a mod to armor piece (for Warsmith) Just in case the step was supposed to be the same as the Epic Weapon step to modify weapon.

I think when I did this in LIVE, I just had to take off and put back on a set of Epic armor.

was also tried whithout resolving the issue

Had the “wear epic armor” step fail today on a character who wasn’t wearing epic armor. Crafted the first piece of epic armor for this character. Craft epic armor step completed. Put the same piece on and the next step did not complete.

tried several times to no avail. Even tried relogging and restarting the client before trying again. Still happening for both Warsmith and Master Armorer.

Post today’s patch I tried both Warsmith and Master Armorer journeys again. I removed and re-equipped a piece of epic armor and was able to complete them both. Thanks dev team!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.