Well of Skelos bug I: Courtyard Door

Basic Info:

Platform: PlayStation 5
Issue Type: Gameplay
Game Mode: Single Player
Server Type: Singleplayer
Map: Exiled Lands
Server Name: N/A

Bug Description:

In the Well of Skelos dungeon, the door connecting the first large courtyard area to the second large courtyard area (with the stone table) does not open. Even after backtracking and removing the bracelet to restart the dungeon. In the end I had to go into the Admin Panel and activate ‘ghost’ in order to progress past it. Hence it is not possible to complete it without cheating onSingleplayer.

Bug Reproduction:

  1. travel to and enter the Well of Skelos
  2. progress to the first courtyard area leading to the second with the stone tables/benches
  3. notice the door will not open
  4. cheat in order to progress and finish the dungeon

Dumb question: did you kill the miniboss? The door used to be bugged and opened up on its own, but some time ago they fixed it and now it only opens when you kill the serpent-man miniboss.

1 Like

Also it is possible to bypass it by climbing down, jumping over a lava stream and climbing back up. Not ideal but it works aswell. That’s what I used to do before I knew I had to kill the miniboss as @CodeMage said

1 Like

Not a dumb question at all. But first a little context. I had not run this dungeon for a considerable period of time now; I believe back in 2018 or 2019 was the last time(?). It was was also bugfed back then when I ran it last, hence why I decided to report it now. I am almost completely certain that I cleared the entire first courtyard outside the door, as I was hoping to land small treasures as I went through. But just to be absolutely certain, which mini boss were you referring to CodeMageand is helocated in the courtyard?

I will try to run it again and recheck as soon as I can, but I may not get to until the weekend…

Good to see you are still around @tobi04! I did not know about this. When I was unable to progress I tried to climb around to the right, but it told me that climbing is not allowed there. I will definately keep this solution in mind and use it if I need to.

If we’re talking about the same courtyard – the one with several lava pits – then yes:

Here’s a closer look:

Kill that dude, and the door should open:

More of an around again but honestly not really motivated for Conan right now, the new stam makes PvP a bit weird. Probably gonna play other things for now.

You can’t climb right next to the door but if you’re further away, it should work. Iirc there is also another way you can take from the forge to the boss where you have to jump over a kinda tall gap with a lava stream down bottom. You should be able to see it if you look towards the boss from the forge. There also is a chest spawn there if that helps to find it

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.