Wonky Thrall Pot

Platform: Steam
Issue Type: Bug
Game Mode: Single Player
Server Type: PvE
Map: Exiled Lands
Server Name: None
Mods: The problem existed before I started using mods.

Bug Description:

Thrall pot doesn’t always work. Sometimes thralls take from it, sometimes they don’t. There doesn’t appear to be any pattern to it but it can leave an army of thralls without access to healing. Given the new Purge system’s overhaul of enemy waves this puts them at a disadvantage against AI enemies. I’ve been told this has been a longstanding issue. Since the Age of War is so Purge-focused I feel it might be a good idea to take a look at the thrall pot again due to the obvious benefits it provides during a Purge.

Bug Reproduction:

Just placing a thrall pot with food and thralls around it. May work as intended, may not. Tried multiple thralls, multiple foods, added & removed pots, relocated pots or thralls, etc. No consistency; it either works or it doesn’t.


Has been for a while. Work around is thralls will take jerky from a dryer.


Thrall pots have been bugged or broken essentially since they came out but I think at the beginning of 3.0 they tried to implement a fix where thralls would stop taking out food until they slot cap. The fix failed and instead made thralls pots unusable (they used to have a list in them that shows you what thralls are connected to it). It’s been this way for over a year now… don’t hold your breath.

Like the sated bug, which has also been around since early 3.0, it has been determined that this issue is the lowest of the low priority wise.

When bugs have been around this long its best to just accept them as unintended features of the game. For example, for several years Lian has been bugged to always do 100% full combos (unless staggered) with a 1h mace. They’re never going to fix it so might as abuse it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.