Admin password abuse

Game mode: [Online | PVE]
Problem: [Crash | Bug | Performance | Misc]
Region: [Here]

There is a major problem with the fact that the Admin rights is accessible on official servers, opening the door for trolls and grievers to become gods. Combined with the lack of moderation due to the number of servers means this problem will never get fixed until the Admin rights field is removed from official servers settings page.

I’ve read about people complain about players using about admin rights on official servers, and didn’t pay it any mind, since I don’t give people a reason to abuse me in game. I’m friendly, helpful and will pass off/share loot, even with other clans. However, I got struck by somebody that was obviously using administration rights to troll me and make me loose everything I had on me + my pet.

I know this was somebody with administration rights, because no glitch would do what happened.

I was out farming star metal being cautious of my surroundings, and headed back to a temporary camp I had setup on the frozen lake. Taking the normal path down from the ice giants, I initially didn’t see anything threatening. Then I witnessed a 1 skull white Saber tooth spawn in infront of me. I didn’t feel like fighting it, so I attempted to go around unnoticed. Suddenly I watch another 1 skull white Saber tooth spawn in 15ft in front of me. The music started to kick in, so I attempt to turn and run towards a clan base I just passed. 3 seconds into running and a 3rd 1 skull white Saber tooth is spawned directly in front of me. At this point I tried juking around it around getting my shield ready, but got tagged in the back. Before my character can even get up the other 2 white Sabertooths pounce. I immediately chose to respond at bedroom, in the temporary cabin, grabbed my backup gear and rushed to try to save my pet. When I get there, he’s holding his own (greater wolf) but not going to win. I managed to get close and set him on followed attempted to make a break for the cabin. But was met with another white Saber tooth spawning in front of me AGAIN! I’m pissed and frustrated, I and attempted to respawn at my bed roll again, but this time it’s not an option. It was destroyed within 1 minute of use. I’m forced to respond at my main base in G8. I grab my backup backup gear, a rhino head soup, and used my map room to get back to my pet asap. Upon arriving I find my body and pet barely hanging on. 2 of the 4 white sabers are destroying every other animal (including regular sabertooths) in the area. I took an opening to grab my pet and gear but got jumped again by 3 of the 4 white sabertooths, and died knowing I just lost all the gear I spent the last month working towards and a pet I’ve had just as long. The worst part is knowing this wasn’t a simple glitch, but more likely some troll with the administration password, turned invisible and repetitively spawning in one of the most powerful animals in that region, for no other reason then to make me loose everything I worked for.

I immediately rage quit and uninstalled. The next day I jumped in party chat with the remaining members of my clan, only to learn 2 of our other outposts had every workbench and supply crate disappear (suspected glitch).

The discussion turned to possible suspects. One player who shall remain anonymous to all but inquiring devs, came to the front of the list. A very small clan, where we’ve only ever seen one of their members on all a time, they never leave their massive base (almost 1 full map square in size) which keeps growning. A clan with a YouTuber that tried to claim, in one of his videos(since removed), that their base was on a pvp server (really it’s a pve). A clan member questioned his video and inquired how he got an admin password since their base doubled in size over a 24hr period (with t3 dlc pieces). It seems like that questioning was the catalyst for him removing his previous videos and reloading a new video showcasing his “pve build”. Less then 24hr later all that BS happened to us.

[Free text]

Steps on how to reproduce issue:

Hey @Stainless

Welcome to our community.

Did this happen in an official server or private server? There’s no admin password to any official server, so the suspicions in this case are probably not correct. There’s been a bug in the past that would cause NPCs to spawn multiple times in the same spot, which with an extra pinch of bad luck could explain your situation. If it happened in a private server, it could very well be your suspicion of an admin just having a whale of a time.

Regarding other claims with admin rights on official servers, they mostly boil down do the use of exploits and gullible people.


There is a glitch since last patch where on a pvp server you log into admin it shows it as a pve server in the browser even if no settings were changed. I noticed this with my own private pvp server and then also on official pvp 1945 so I was pretty sure someone was logging into admin on that server. When the server restarts it changes the game server browser back to the right label as being pvp. The settings do not change just the description label in the browser. Who ever was logging in to the official pvp server 1945 has stop because it has not change in a few days.

This was in an official pve server. Btw claiming there is no such thing as an administrator password on official servers, yet the field remains active as on any other server, because it’s part of the game is either being gullible or treacherous. It’s the same as people claiming GTA on consoles doesn’t have hacks or exploits. Those people are either gullible or attempting to deny what they know to be true, so they don’t get in trouble for it.

There is evidence of people being able to active admin mode on official servers. Official server settings changing mid session, players floating or taking no damage, teleporting when not at a map room, eye witness accounts describing in detail what occured. And your response is to claim either those people are gullible or witnessed an exploit. Wouldn’t having access to admin panel be an exploit?

Forgive me, but unless you are part of the dev team and coming out with an official statement that it is impossible to access the admin panel on an official server, I’m going to consider your statement as nothing more then opinion. And even if you were a dev, I’d still take it with a grain of salt. The amount of setbacks this game has had since launch, the last thing funcom along with the devs would want to admit, is that there is a problem with people exploiting a function not meant for the official servers, but left accessible. Kinda like how R* denied there was an admin panel in GTAO, even though people found a glitch to access and most cheats exploited it.

He is, actually.


The community team is a direct part of the development team and fully employed and on location with the rest of Funcom. We have direct contact with the rest of the team.

I am going to repeat what Ignasi said and what is indeed a FACT:
There is no actual traditional admin password treatment or any other means that would allow someone outside of Funcom to access any admin settings on our official servers. (I am not going into details on how this is set up from our side for obvious reasons). Yes, the panel is indeed there but it doesn’t serve
any purpose on our official servers.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.