Al Merayah - Falling through floors, getting stuck inside foundations Official server 1730

Official server 1730
I keep falling through the floor and getting stuck in the foundations of the new Fortress al merayah. Have to remove bracelet to escape, losing all inventory and loot.
Animals keep walking through walls into a secured base including the roof. Purge enemies keep getting stuck inside foundation and purge will just hang till I quit game, Over one month of bug reports and no help from Zendesk or devs. This is just a small list of bugs I have found.


So its been three days now stuck inside the lowest formation inside al merayah. I still have food and water. I check every morning to see if Funcom has reset the fortress or fixed the problem. Still no answers from the bug report system except the generic Zendesk reply. I could just remove my bracelet but its interesting to see how long Funcom will ignore their issues.

Have you submitted a bug report using the bug report template submission on the forums?

At least 8 with pictures and its still the same after the January 16 2024 patch.

I’m sorry I’m just not seeing the bug report here in the forums, you’ll have to submit a proper report this way: NEW Bug Report Template

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.