Asura Armor doesn't make Survivalist's Armor

I kind of thought this would be fixed with the latest patch. But it wasn’t, so…


Bug Description:

The Delving Bench doesn’t seem to work with Asura armor.
I’ve tried all 5 pieces of Asura armor. None of them will convert into a recipe.
(Yes, I’ve made sure the armor is fully repaired and there’s over 500 Eldarium in the bench)


Expected Behavior:

The Delving Bench should convert Asura armor into a recipe. At least, according to the wiki.


Steps to Reproduce:

  1. Put Hood of Asura, Chestguard of Asura, Gloves of Asura, Leggings of Asura, and/or Boots of Asura into the Delving Bench.
  2. Add Eldarium
  3. Watch as nothing happens

Survivalist's Outfit

1 Like

Greetings,

Thank you for your report. Our team is aware of this issue and unfortunately, it was left to another update.

Please keep an eye out for future patch notes to check if the issue was addressed.

I can second this. Tried to delve this looking for the survivalist armor and it wouldn’t even delve. I play private server modded, so I went to single player with no mods, admin’d the stuff in, and it won’t delve. This was reported back in April (not sure if it was reported further back then that). This is disappointing that this hasn’t made it into any of the patches. Please note for next patch. Thanks.

I would argue that the Asura stats are more usefull than the one it delves into, but that might be just me being wierd.

Then you’re not the only one. I too think +15 survival is far better than +7 encumbrance & +8 survival.

Stats notwithstanding, I would say the ability to repair the armor with Eldarium instead of legendary repair kits is a major benefit if you want to wear it yourself. For thralls, the Asura set is clearly preferable.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.