Delving Bench seem to be broke

Hi today I noticed the Delving Bench isn’t working any longer. I asked on server and someone mentioned weapons seems to be broken but armor works. I tried both, with like 20 items now, even a sword that used to work for sure, none works right now. I have 150+ Eldarium Bars inside and the play button is active. Doesn’t do anything.

Official Server EU

What are you trying to delve? The items have to be 100% repaired.

It works for me with Hardened Steel Weapons:

They changed it to require 50 eldarium bars

hm some items were not fully repaired. Problem solved. Some of the fully repaired items I tried seems not to work though. But wiki says it should work, like the Black Hand. I assume I can only delve, what I know to craft? They were drops and I don’t have the feat for them yet. Same goes for Black Knight armor. Fully repaired, but I don’t know how to craft yet.

for Armors not working, Asura set does not seem to delve like it should, but that is reported in Wiki already. I haven’t been able to get the black night armor from delving, simply for not having found any Redeemed, Rusted, Champ or God armor to delve. I also haven’t been able to test delving Lemurian Royal or Silent Legion in the delve bench, as I don’t have any pieces of those. All the other armors that are listed in wiki as ones you can delve, I have tested and they did provide the expected recipes.

I try to stay away from the “admin spawn” button for testing, unless I encounter what appears to be a bug.

You dont need Redeemed, Rusted, Champ or God armor to delve to have a black knight. You need silent legion. You can obtain it by summoning a 1000 swirling chaos (20 greater ??? essences, 500 unstable) West surge, then just delve a single piece.

I thought Silent Legion was one of the sets that delved into Chieftain armor?

That was before latest patches, which one tbh I cannot answer to you, but right now it delves to Black knight.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.