Delving Bench Crafting Issue

Game mode: [Online private]
Type of issue: [Bug ]
Server type: [PvE]
Region: [NA]

I’m currently unable to activate the delving bench. I have used hardened steel weapons (thus far) at full durability, with 20+ eldarium bars, and ensured I pressed the ‘play’ button. Nothing seems to happen. There are no mods on this private server and I can’t seem to find any item (yet) that will work in the bench. I tried this out on single-player/co-op play and the bench worked fine, even using the identical hardened steel items that I tried on the private server.

To clarify: I have tried to pick up and replace the delving bench. The items don’t disappear, they sit in the delving bench inventory doing nothing at all. I get no recipes or broken weapons.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Craft/Obtain hardened steel weapons at full durability (e.g. hardened steel greatsword) and place in delving bench.
  2. Place enough (20+) Eldarium into the bench.
  3. Wait for the items to delve, but nothing happens at all.

You need 50 eldarium bars now because you get a recipe with 100% success rate.


Oh that’s fine! I haven’t played Siptah recently but I remember spending much more to get a single recipe because of lower success rate.


Wow really? I’ll try and get 50 bars and report back to confirm. I wish someone had said that in the other 15 threads I searched lol! Much appreciated.

1 Like

To confirm for anyone else who reads this in future: It is indeed 50 bars with a guaranteed recipe. Thank you very much Narelle. Works a charm.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.