Delving Bench Issues

Hi, I’m either missing something or the Bench is completely bugged out, I have tried everything possible and it just won’t craft, I have 400+ eldarium in bench and I’ve tried so many armour sets and weapons to no avail.

I’m trying to complete the journey step and it just won’t do schematics.

I’ve also followed so many online tutorials and still nothing.

Am I wasting my time or just missing something obvious.

I’m on PS5 and great internet.
Map is Siptah

Thanks for any help.

Have you tried just crafting an item to delve? Some legendary items and some armor sets don’t actually delve.

Ye I tried some darfari gear but nothing, also tried a few light armour and also did nothing. Friend said she used Cimmerian armour so I tried that to, got nothing :rofl: well I say nothing, I mean a headache lol I just don’t get it.

Ok… gonna try the “is it plugged in” approach… are they full durability? It won’t work if you use items that are even a hairline damaged. I’m sure you probably know that, but I wanna be certain.

Ye I tried that :rofl: does the bars go in top and with items, I tried bars and items in top and bars in top and items bottom. Baffling me lol

1 Like

Yeah, they do… hmm… are you on official, private, or single player/co-op?

i have that same issue, even going by the old published items to delve to get item recipes, even from the basic weapons and armor you can make to delve on the bench, do not work, do you have any insight on the issue, im on an official server, isle of siptah

1 Like

You guys want to a funny one. I wanted to do the journey step put variations of items until I realized my wife made the bench. Going to have to respec or find fragments or bring her character in to test.

Greetings RogueBudda!
Thank you for reaching out to us.

In order for us to properly assist you could you confirm two bits of information with us please:
1 - In which server is this occurring?
2 - The Journey you’re referencing is the ‘‘Delver’’ correct?
3 - Are you referring to the ‘‘Craft an Eldarium Weapon’’ step?

We’ll be waiting for your reply!

Single player, played for a few years but haven’t played siptah, was always Exile lands, but then I quit the game cause of all the issues, but now I want to give it a fresh look and thought give siptah a shot lol.

It’s happening on single player, it’s the step that says Learn a delved schematic.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.