Delving Bench BROKEN STILL

Delving Bench is still broken since the update. There are many armors that I have tested that will not give a recipe. Light, Med, Heavy armor and Kambujan are a few.

1 Like

Just tried on my offline server kambujan, hyborean slaver, heavy helm, silent legion. and nothing! I don’t think these benches work for armors. I did about 100x of each of the above

I can confirm that the Delving Bench seems to be acting very stingy with armor delving as of patch 2.1. If this is intended it is brutal and not fun (to me or my server-mates). I would be a vote in favor of increasing the chance, even if it is less than at initial early access. We can only chalk it up to RNG until everyone has the same issue.

Tested on single player because i was getting suspicious on official.
200 silent legion pieces = 0 recipes. and thats after wasting armor pieces on official server from like 5 T4 surges. Funcom im upset.

Same…was briefly excited that the bench would work…but nope

Ah you know how it is with funcom, each hotfix needs 20 of its own hotfixes

3 Likes

Any news on this?

This still a thing, trying to get frost giant armour and only getting pride of aesir endlessly. Are all armours broken or just a few?

Looking at the DevKit, these seem to be only working armor schematics at the moment:

  • Climbing Recipe
  • Khari (all 3 recipes are available)
  • Pride of Aesir Recipe

So every other armor schematic appears to be unlinked as reward. Weapons look fine.

1 Like

2 options, :
1 they removed the recipes and forgot to tell anyone
2. they broke it (unintended)

I want to clarify that the recipes are there but unlinked. Updated my post as well.

Fixing the bench should be off some urgency, people (myself included) dont want to burn mats for nothing.

Edit, just wasted 300 eld on starmetal greatsword on offical server, nothing in return. Worked in single player though. Cant be just rng saying “screw you charm”.

yes, i meant, they removed the recipes from the delving bench, you can still get them by killing the judge, (very very tiny chance of dropping the recipe)

1 Like

True, i have killed The Judge 54 Times. No recipe yet, today going to give it another try.

As Siptah is Early Access, i just stash armors/Materials for when the Delving Bench it will be working as supposed to.

1 Like

I have confirmed that all the armor I was having issues was fix on the update a week or so ago.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.