Authentication/Log In Error

I’m a lapsed player, haven’t played or logged in a year or more. I’ve been playing a lot of Conan Exiles and it’s gotten me to want to revisit Age of Conan. Every time I attempt to log in I get an authentication error. I’ve reset my billing and game passwords together and individually over the past couple weeks without any result. Any idea why i’m not able to get into the game. I can get into my account just fine and see all my items, my products and points, change my passwords but i can’t actually play the game.


1 Like

Are you trying to play through Steam? Or the game download from the account page? I would make sure you are on the latest version.

I’m planning through steam this time around. Does that make a difference?

Should work regardless. Try the Steam

I’m using steam, downloaded the most recent version, and still have the same issues. I tried contacting support, but it’s been nothing but crickets from them unfortunately.

Could you try a VPN to another country?

I’m having the same problem as well. I have no idea what is going on. Can’t even send in a email support, either. Yes I’m using the recent version from the website. Have even reset my password multiple times. COME ON FunCom, give us a break please >.<

Try “repair broken data” and select the check mark after, I think it’s compress data or something… it works for me. I hope it works for you guys.

1 Like

that worked for me. thanks alot.