Battle Pass Unable to Claim Reward

Basic Info:

Platform: PC
Storefront: Steam
Issue Type: Bug
Game Mode: Single Player
Server Type: PvE
Server Name: my own PC

Bug Description:

The Battle Pass will not let me claim a reward to collecting stone:


Upon restarting the game, then this message shows up:

Is it possible you were disconnected from the Funcom Live Services network? Maybe try closing the game completely and restarting? :man_shrugging:

Same error here. Nothing I do will let me claim the challenge.

That’s what I’m saying. I have completely closed out the game and restarted. Twice now. Same result.

Me too. I have fully restarted the game twice. Even restarted my entire PC.

So when the game reloads, you are getting successfully logged into Funcom Live Services?

When the game reloads, I do not have any trouble logging into Funcom Live Services.
When the game reloads, the Battle Pass and Bazaar fail to load.

Restarting for the third time, this time, not from the launcher “continue” button, but from “launch” did seem to work. The Battle Pass and Bazaar are now back. I suspect something happened on Funcom’s end that they got it back. The steps I took do not seem to logically affect the Battle Pass and Bazaar since it stopped working “mid-stream” (as in, I had already turned in a few rewards before it suddenly stopped working).

My completed “stone harvest” however did not return. It looks like I will not get credit for that one now that the Battle Pass has opened back up again.

Greetings @Bodin,

Please send a ticket to our Help center and select “in-game purchase” as the reason type.
Make sure to share your funcomID and any additional information you might have.

Thank you in advance.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.