Blunted Javelin cannot be outfitted with Blunted Fittings

Game mode: [Offline | Singleplayer]
Problem: [ Bug ]
Region:


As the title implies the Blunted Javelin will not permit me to apply Blunted Weapon Fittings to it in order to increase its concussive damage output. I tried with both the (regular) blunted weapon fitting, and also the advanced blunted weapon fitting, be to no avail for either.

Now there is a couple of things I felt it best to just put out there in relation to this bug report. The first is that this restriction may simply be intented; I am unsure. The second is that PS4 is of course still at version 1.61, and this may or may not have been fixed internally in one of the post Siptah updates. Finally, certain other modifications have proven temperamental for other items beforehand (eg-we currently cannot use reinforcement kits on Torches), so this bug may of may not be an extension of this.


Steps on how to reproduce issue:

  1. Craft a Blunted Javelin
  2. Craft either any type of blunted weapon fitting
  3. Attempt to combine or ‘attach’ the fitting to your Blunted Javelin
  4. Recieve the ‘cannot modify this item with this modification’ message
2 Likes

As far as I know, no javelin can be modded with any fitting. It falls into the same category as throwing axes and throwing knives, which also cannot be modded or fitted.

1 Like

Welcome back.

1 Like

Has this always been the case from the get-go CodeMage…? It is quite possible that it has, escaped my attention all of this time. While I do on rare occasion use regular Javelins in combat for a change or warped humor value, I have still never actually used the Blunted Javelin prior to now. It was honestly one of those things which I simply always forgot about.

This is counter-intuitive. While I can understand it being classe as a ‘throwable’ projectile weapon, I feel it is in a class above throwing axes and knives in the sense that it has combo abilities when used alone, it is a right hand weapon, and has a durability meter. I guess I just expected it to be more ‘customisable’ like Bows or other primary melee weapons.

1 Like

Thanks Sestus, told you I would be back soon mate. :wink:

2 Likes

I’ve never been able to attach anything to any of the weapons I mentioned, but I can’t recall when was the first time I tried. Sorry :man_shrugging:

Yeah, it sucks :confused:

2 Likes

You cannot dismantle it in a dismantling bench either.

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.