Bountiful chests not activating treasure coffer

So far I waddled back to my treasure coffer & accountant with 2 of the bountiful treasure chests BUT I cannot seem to find any way to get them to add to my coffer tally. Results so far include:

  1. the gold “aura” indicating the tally zone around the coffer does not highlight when I enter the proximity of the treasure coffer when I am carrying or lay down the bountiful chest. So far on Siptah, ALL other treasure items I’ve found (harps, urns, horns, etc.) all show the gold glow & are registered.
  2. From a (PC?) suggestion, while carrying the bountiful chest, I’ve both square clicked on the treasure NPC & the coffer many times, but still no change in registering the chest.


  1. has anyone else had the same issue on a Siptah server?
  2. are there any practical fixes for this obvious bug (according to all the YouTube experts, a bountiful chest should activate the tally zone around one’s coffer just like the other treasures) or are we stuck waiting for it to be patched eventually?
    … like we’re still waiting for English language servers to actually show dead NPC’s names in English, not German. I mean, that’s only been going on for the last year & several patches :roll_eyes:

Official PvE #8080 Isle of Siptah

1 Like

While carrying the chest, click the attack button to place it down as claimed treasure.

1 Like

I’ve clicked every button on my PS5 controller to no effect. The chest had evaporated the next day so I cannot recheck that action but I believe clicking either R1 or R2 “attack” buttons simply dropped the chest. I still think not showing the treasure zone aura is the crux of the problem.

The aura effect will show up when you press the attack button while carrying the chest/treasure, as long as you’re near your coffer, allowing you to place it down and claim it. Simply dropping it will leave it unclaimed, and it will eventually despawn.

I don’t use a controller, so I don’t know the default buttons, but a previous PS5 user that was having the same issue did say that using the “attack” button worked for them.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.