Bug can’t change the avitar lifespan in custom game

Game mode: [Singleplayer]
Problem: [ Bug ]
Region: [Custom]

[Its stuck on 30 but if I set up a new map it’s on 60 and i can’t change it I don’t know if it’s a bug or something else but please help

Steps on how to reproduce issue:
1.make new map
2.go to settings
3.go to combat and avitar lifetime
4. Won’t move

@Monkeyboi are you on pvp building damage on . Set mine up to 120 seconds SATURDAY. You may also have to uncheck a setting.

1 Like

I have that off but it’s just pvp enabled or not and when I check it on or off it doesn’t change it I still can’t move the slider. What settings do I have to change to get that to unlock

You are playing offline right? Or your own server. If not you can not adjust. I did it last on my server but used the ingame settings with out being home I couldn’t tell you haven’t done this often sorry. @Croms_Faithful can you help or know who could. Thanks.

I’m playing on a single player co-op and if u make the game u can’t switch the aviator setting it’s gone off the settings in game but the one I always play on with my buddy is stuck on 30 but I don’t know why because default is 60 if u make a new one but I couldn’t switch the 30 because it won’t allow me to do it

Ok understand 30 seconds doesn’t get you anywhere. If CROMS Faithful can not help he knows alot of people who play offline I will check back at lunch gotta go back to work.

Ok thank you

Sadly folks I have only ever summoned a God once for the Journey Step, and that was close to a year ago now. When I did so Im fairly certain it was 60 seconds, but please do not hold me to that. Maybe @Wak4863 or @Barnes would be knowledgeable in this area. Maaayybe @WhatMightHaveBeen, but I think he sticks to officials, so he may not know.

I don’t know what to say about this specific setting. However I will note that in order to change any of these settings you have to make yourself admin, then back out of the menu and go back in. Once you’re back in you can then make changes to the settings.


That could be the answer I was using admin while taking down a base. And it would not damage anything unless I turned off server and restart Yog just flew around spewing and doing know damage even when he smashed to the ground . Not wanting to restart server I did it the fun way busting foundations

I can try that and see if it work and if it still doesn’t I will let ya guys know I might even be able once u create the game

I tryed about a hour ago and I can’t switch the Avitar lifespan in game I think you have to do it before u make the game and u can’t switch it because when I’m in game there’s no setting for lifespan

Some settings can only be switch before you start the game and they may be removed so it could be a start new game to change the settings for instance land claims settings can only be altered before you start the game

From what I know I have never been able to change the duration of any avatars in single player (xbox) they have always been stuck at 30 seconds and the settings are broken

Ok thank you guys I don’t think I can switch it thanks for all the help and the support

1 Like

Hello @Monkeyboi, welcome to the forums!

We’re aware of this issue and it should be addressed as soon as the team is able to tackle the Avatar related issues and balancing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.