Bugs with Darfari armor and zamorian thief "flawless epic" armor


#1

Game mode: [Online]
Problem: [Misc]
Region: [America]


I’ve noticed 2 bugs with crafted armor, for some reason repairing epic darfari flawless armor gets stuck on repair (it acts as if it’s being repaired and wont let me equip it). I haven’t tried with regular flawless or epic.

The second thing is the “Irniz of the furnace” will craft the regular flawless version of the zamorian thief armor, but it won’t make the “flawless epic” in the improved armourer.


Steps on how to reproduce issue:

  1. Irniz of the Furnace on an improved armourer’s bench for the zamorian thief option missing (flawless specifically).
  2. Any thrall that can make Flawless darfari armor. (I’ve tried with ogrus the iron-eater)

Repairing Shaman Helmet stuck on Repairstatus
#2

I have the same problem with Darfari armor, apparently it’s not only the Flawless version that is bugged but the Epic normal too :frowning:

The basic version and Flawless ot epic are working normally.

And yes I also noticed Irniz of the Furnace can’t craft Epic Zamorian thief armor :frowning:


#3

Apparenly, it’s fixed in last test live patch, I just switched today to test it and I was able to repair my Flawless Epic Darfari Armor <3

All armors thralls seems to be fixed too :slight_smile:

Thanks Funcom !


#4