Buildings Dissapearing!


#1

Game mode: [Online Private]
Type of issue: Bug]
Server type: [PvP-RP]
Region: [America]


[I had built everything on Stonebrick. No modded content was added. Yet after restarting the server, literally all stonebrick buildings we made despawned. I think you guys screwed this game right after this new update of yours. Thanks for that. - Ruined my weekend…]


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Make a stonebrick building
  2. Restart your server
  3. Rebuild your stonebrick building
  4. Restart your server again
  5. Ragequit

#2

Have you tried reverting to a previous save?


#3

Our server has tried this multiple times.


#4

Okay, was it just stonebrick buildings?


#5

Yes. All just stonebrick buildings. We built it mostly on ceillings and pillars, and a few foundations.


#6

Thanks for the clarification. I can’t say when I can (and I’m currently in Nvidias slow live chat trying to resolve a dev kit issue), but from my modding perspective end I’ll see if maybe I can find what’s going on in the dev kit. Otherwise I hope someone else can chime in with some suggestions while I investigate.


#7

Is it possible to verify the install version of the server? Like there is with Steam’s client? Like check to make sure it’s the correct version, that no files got messed up when it got updated? I’m also not sure if the server is through a 3rd party provider (rental), or a home PC.


#8

It isn’t my server. But the admins decided to do a full wipe, without mods. And then add mods on as they get updated. - But this same issue seems to keep happening all over, even on unmodded and official servers. And every single time, not with modded content like you’d expect but with base game content.


#9

Oh, I thought you said you weren’t running any mods. Since so many mods were affected by this patch, that was likely the case here as well.


#10

Miscommunication or clumsy way of me to explain it. But I meant with ‘no custom content was added’ as that there was no custom content added anywhere close to the building we had made. But yes, possibly. The wipe might help. I hope it does. But I’m quite anxious it might not. I’ll keep this updated a bit to see how it goes.


#11

Wipe might not help if it’s a out dated mod affecting it. Do you know what mods you are running on the server?.


#12

can i ask which mods was on your server? as this has happened to 3 buildings on our server too,
first one which was mine was in khitan style then rebuilded in sandstone and it happened again but now another got it happen to him also.
mods used not in this order though :wink:
Emberlight
Savage Steel
Pippi
Jungle Building Set
Dye More Betterer
LitMan Item Stacks
Fashionist
Exiled Architect
Birds of Passage (tent mod)
Forged Decor
and Unlock Plus.


#13

We’ve had a similar issue for a few days now, entire villages and half-buildings suddenly disappear after a restart. In the event log, same thing: “lost stability” for some obscure reason. It’s starting to be a problem =/


#14

Any mods? Stability is a really finicky thing sometimes (I’ve spent way more time on stability via modding then I care to admit).


#15

Pippi (https://steamcommunity.com/sharedfiles/filedetails/?id=880454836)
Primal Armors (https://steamcommunity.com/sharedfiles/filedetails/?id=1427509507)
WARRIOR Mutator (https://steamcommunity.com/sharedfiles/filedetails/?id=1402835318)
Gardener (https://steamcommunity.com/sharedfiles/filedetails/?id=895167522)
Unlock Plus (https://steamcommunity.com/sharedfiles/filedetails/?id=877108545)
Sir Vival’s Immersive Clutter (https://steamcommunity.com/sharedfiles/filedetails/?id=896237988)
Cupcake’s Aesthetics (https://steamcommunity.com/sharedfiles/filedetails/?id=1391805405)


#16

And you have been having these issues before the major patch or after? I know for sure Pippi has some major issues atm (though I kind of doubt it would affect stability, but major patches like this are unpredictable in terms of what will happen when a mod uses old blueprints and it conflicts with new blueprints).

Is there any consistency behind what goes missing due to stability errors? Like are you using the same buildings in the areas that go missing, or is it a variety?


#17

It’s a wide variety of things. Vanilla T1/2/3, Warrior mod buildings, foundations, fence foundations, pillars, old buildings, new buildings, there doesn’t seem to be consistency (at least none that we managed to find, so far).

The first buildings disappearing were reported just before the patch, after the daily restart.


#18

on our server it was khitani building that disappeared first, after that 2 sandstone buildings, some on our server suspects that it might conflict with the new baby spawns, since the second house was close to some baby spawns, mine that was the khitani that i tried rebuilding now twice is in the ruins behind child of jhebbal sag, actually kinda perfect hidden spot there ,-)


#19

I’d like to add that, while it’s true and we had two cases of building parts disappearing before the patch, I can’t rule out the possibility of that being just a coincidence and unrelated to the much greater amount of buildings having vanished after the patch.
There have always been a few things here or there that went missing after a restart but the occasions of this happening were far and between.


#20

We’re running Warrior Mutator, Age of Calimities, Pickup Plus, Fashionist and Pippi. And the only mods adding anything to the database buildingwise is Warrior Mutator and Age of Calimities, but we’re not using the building parts of either mods.

Our server wiped last night, and people’s buildings are still dissapearing. But because of the recent Funcom patch giving more information in the logs, we received this in the logs: (it shows the drawbridge, and the entire structure was destroyed by . )

I have a screenshot of the log too. But I cannot post it because of the discrimination of these forums demanding me to have 100s of hours into this forum or something before I can post links.