Can not remove any thrall from their craft stations

Game mode: [Online ]
Problem: [ Bug ]
Region: [USA]


All the thralls I have at craft stations I can not seem to remove. I tried every way and to get them back I need to destroy the workbench.


Steps on how to reproduce issue:
1.
2.
3.
4.

1 Like

Can you swap the thrall for another? For example get a lvl 1 thrall and swap it for the one you want back.

No i tried it too…

Damn, that sucks. I was disassembling someone’s decayed base today and every crafting station I destroyed dropped a bag that had everything from the CS in it including the thrall. Not saying this will work but might be your only option.

Reporting this to the devs to investigate, thank you!

I have this problem as well, but I WAS able to swap one thrall for another. Try:
Select the thrall in the station no yellow selection outline will appear around it
Then, select (replacement) thrall in inventory. Despite no animation, I was able to swap my T1 carpenter for a T2 I had just broken.
Hope this helps.

I will try, thanks m8

1 Like

Yeah, I’m able to move crafting thralls in and out of stations. It’s a bit confusing as the thrall icon no longer gets highlighted when selected, as mentioned above. Just click on the thrall to select then click an empty slot in your inventory.

PS4

I did it many times and nothing happens

I found I have to put thralls into the craft bench from the thrall slot then I can move to my inventory, and to put in the thrall slot I must move it to the craft bench inventory then move it to the thrall spot.

i tried it too

is your inventory slot on custom? if it is a sort option it often causes issues moving them in and out of craft tables

1 Like

Case solved… many tanks to all.

What i did… I destroyed the workbench, after this i was able to place a new thrall and remove it when i want in a new workbench

This topic was automatically closed after 7 days. New replies are no longer allowed.