Cannot connect to friends server

During the free weekend of the game I played a lot with my friends and it was working perfectly fine (we play on his server). Ever since the games free weekend was over and we purchased the game, it would no longer let me join his game. I tried restarting my computer, reinstalling the game, restarting my router, release/renew the IP, and other things as well, but nothing seems to work, does anyone know what to do? Our other friends can still join the server but only I can’t any longer. I also can join other servers only his I can’t join.

Hey @ChaldoMatt

We’re sorry to hear you are experiencing issues. We recently made a thread with the most common technical issues and solutions here:

Also, is your friend’s server a listen server or a dedicated one?

I am not entirely sure but all I know is that he port-forwarded the server and runs it off his IP for us to play. The server does not appear in the “Play Online” tab either, or if I try to find the server through

  • steam view, servers, and look for his. It still won’t show

It also says either “Server not responding” when i try to join through steam, or “Could not connect to server. Your connection to the host has been lost.”

It seems then that your friend is running a listen server. He could try to create a dedicated server by running this tool here:

On that thread there is also a really in-depth guide that covers most of the basics and general troubleshooting. On top of that, the advantage of running a dedicated server instead of a listen server is that you’re not tethered together anymore.

He created a dedicated server I am pretty sure. There is no tether distance, he port forwarded and it runs off of his IP. I can join his game when he runs it off of the game (through the built in co-op feature) but when he runs it off of his server it does not let me join.

Our other friends can join I am the only one with the problem of not being able to join.

Hey @ChaldoMatt

Have you tried going through some of the troubleshooting steps listed in the thread above?

Yes, none seemed to do anything

I am sure you have tried this already, but just to be sure. Did you have the game closed before trying to connect via steam? If you have it open and then try and connect via steam, it sometimes won’t work.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.