Cannot connect to private server

Game mode: Online
Problem: Crash | Bug
Region: U.S

Me and my buddy pay for a server and we have been playing non stop for the past ten days. All of a sudden, he is not able to log onto the server and comes up with a message that says failed to connect to host. The way we worked around it was I had to invite him to the game. Last night, everything was fine for me and then when I tried to get on, I now have the same issue. What exactly is causing this problem and is there a fix for this? I have tried everything and I cannot get on. It would be really disappointing if me and my friend can’t connect seeing that we put a lot of time into that server

Steps on how to reproduce issue:

  1. Tried to log onto private server

I was having this issue last week. What worked for me was restarting my server and Xbox, and unplugging my network cable.

This thread addresses it in more detail:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.