Cannot log in to Funcom Live Services, unless VPN is used

Platform: Steam
Issue Type: Other
Game Mode: Online Private
Server Type: PvE
Map: Exiled Lands
Server Name: =SERVER NAME=
Mods: None

The game cannot connect to Funcom Live Services, every time I launch it, the connection just eventually times out. I play on a private server online with a friend. We don’t use mods, cheats or any glitches (mentioning this because an account ban was mentioned in threads like this). The title worked the day before just fine.

I tried reinstalling the game, verifying the file integrity via Steam, rebooting Steam, restarting the PC, rebooting my router, relogging to Steam, re-adding the game to firewall exceptions. None of this worked.

However, after I saw similar reports here mentioning people just can’t log in from their computer, but can do so from another PC in the network, I tried a VPN (pointing to my own country). And it worked.

But it slows down my connection, it is not something I’d like to rely on. Why can’t my PC just connect, especially if it was working fine the day before? Please assist me in making me able to connect without a VPN.

I also filed a Zendesk ticket (which does not mention a VPN, since I didn’t try it at the time): ticket number 96291

Steps to reproduce:

  1. Launch the game
  2. Wait for the Funcom Live Services to log in

Observed result:
Connection times out, unless a VPN is used.

Hi @death_stealer

If you’ve already summited a ticket to our team over on Zendesk then please be patient. The team will get back to you as soon as possible.

Thank you for your understanding.