Can't delete map markers


#1

Game mode: [Online]
Problem: [Bug]
Region: [EU]


I can’t edit any of my map markers to delete them. When i try and right click on the map marker, my only option is to add a new marker. Other players on the server report the same issue.


Steps on how to reproduce issue:

  1. Add a marker to the map
  2. Right click to edit

#2

Isn’t right click reserved for admin teleport? I use a controller so I’m not sure, but I select it with the crosshairs as if I’m making a new one and the edit window comes up. Choose the red / and that deletes it.


#3

I don’t have a controller for the PC, i’ll try and borrow one and see if that works. I can’t select the map markers with left click or right click. It just tries to add a new one every time. :frowning:


#4

I’m not saying you have to use a controller. Just move the red crosshairs over the marker. I believe they’re there whether you use a controller or not


#5

Nevermind. I just checked and I am totally wrong.


#6

thanks for checking :smile:


#7

I had this issue, go to the marker editing (press edit) the color they chose to highlight the icon/markers is pretty much invisible unless you look very closely and notice the little clear thing it has in the top part of the icon. You want to click on the red slash thing on the top left of marker option window and press it. It will delete the icon and marker name you listed. Hopefully this works for you and hopefully they change the highlight tint when they have a chance, haha. Cheers!


#8

Right clicking on a marker with a mouse brings up the “Add Marker box”
Using a controller brings up the “Edit Marker” box.

So for now we do have to use a controller to edit or delete markers on PC.


#9

Sorry, I just noticed this was the PC forum, I am coming from console but I would imagine the highlighter is the same tint, unless the mouse or another key/button is used.


#10

Has anyone tried to fiddle with the Input.ini on PC to see if there’s some action that’s just not mapped to any PC control atm?

I skimmed over it and found that there’s the action MapSelectInput that’s only mapped to Gamepad_FaceButton_Top and not to any standard keyboard shortcut.

Perhaps if someone were to map that to a valid key, and try to use it while in the map, it could maybe work? Maybe?

I’m at work atm so I cannot test for a couple of hours more :cry:


#11

Yeah. There are three input files and I’ve had to use them all to rebind certain keys. I checked all of them and the only thing regarding map markers is “AddNewMapMarker”.

I don’t see MapSelectInput in any of them. I’ll try creating a new entry.


#12

That’s strange! :astonished:

Here’s my whole line, in case you need it :slight_smile:

ActionMappings=(ActionName="MapSelectInput",Key=Gamepad_FaceButton_Top,bShift=False,bCtrl=False,bAlt=False,bCmd=False)

EDIT: Now that I think about it… I did use the Reset to Defaults option when the big patch release came out and I started a new game… perhaps that’s why I have it?


#13

Thanks.

Maybe. I’ve seen a few threads on weird input issues, so I wouldn’t be surprised if mine was just messed up somehow.

I tried it. No luck.


#14

:sob:

Let’s hope they fix it in one of the coming patches then :frowning: I know that at least in my case, my map is in need of some tidying up :smiley:


#15

Yeah. For now I can just use an Xbox controller to delete and edit markers, but not everyone keeps one handy for the PC.


#16

cant be so hard to fix… or discover before going live… and there is a hard limit on the number of symbols you can place… which is stupid… as well. :confused:


#17