Cant equiped main hand weapon

Game mode: [Online
Problem: Bug |
Region: america

second time my lvl 60 sudenly can not equiped main hand weapons at all tryed posts from reddit about un equipting and re equipting still does not work can equiped 2h weapons and off hand only. tryed dropping all iteams and putting back on still will not let me equiped my main hand.

Steps on how to reproduce issue:

I have the same proble twice . This is rediculous. Cant play this game. I cant equip my main han weapon or pikaxe. Cant harveest, cant fight with one weapon. This happened because I fell from a cliff and died. Respawned at bedroll and bug.

I tried reloading the game. Tried to reload the server. No use
Tried putting os4 controlled off and on, no use.

I need solution, other wise this is waste of time

empty your hotbar items in a box, equip a two hand weapon in top slot (is it slot 1?) and attack with it, after that you can equip and use all weapons and tools again

Thank you very much, it works, but…
Now the controller buttons not workinf R1, R2, L2
Nothing happens when Ipush these buttons. Very sad really
I can equip now but cant use

I have reinstalled the server, now its fine.
Thanks alot