Cannot Equip Items in Main Hand... SOLVED (At least for me!)

Game mode: Online
Problem: Bug
Region: US

So my wife ran into this problem on our server, she was fighting with an Axe / Shield and got killed, next thing she knows, she cant equip anything in her main hand. Off hand is fine. We found several threads on this from both the PS4 and the PC and none of the suggested fixes worked for us, save one…


The reason I am posting this is for 1, the other thread on this was closed and I wanted to let the Devs know that the problem still exists and when all other suggestions failed, the Bow worked. She even recreated her character and when she died again, the bug came right back. Now here’s the odd part, after fixing it with the bow… she died a couple more times and has been fine since.

One question a Dev did ask in the previous thread concerning this… YES, she did change her character’s default size on creation.

I hope this helps some of you guys

Steps on how to reproduce issue:

  1. Die
  2. Cannot Equip anything in main hand
  3. Shout, swear, shake fist at TV
  4. Recreate Character
  5. Rinse Repeat with step 3 increasing in intensity

Hello @Spawn2031, thank you for your submission and for sharing your findings with the community!

Could you please also reference the armor she was wearing when she died?

Yeah, she was wearing the Vanir Heavy set and she was fighting by the Great Dam.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.