Can't join Raidfinder anymore

Problem: since 3 days I’m constantly “Active as: Tank” with my Bear Shaman(!) and I can’t join Raidfinder anymore.

Looks like that:

Leave-Button doesn’t work
Relogging/Restarting game doesn’t work
Petition unanswered

Any advice on how I can fix this problem?

Best regards

1 Like

Let someone invite you into a group (and then leave it again), that might fix the bug. At least that worked a year ago when I had this problem a few times. If it didn’t work, also try to invite others into your group (so you are the group leader).

Thank you very much for this advice. After a few attempts with group invitations the problem has now disappeared and I can log back into the Raidfinder.

1 Like

hey this problem occured to me as well but i was ranger and stucked in que as healer
it happened after it ported me solo to rf instance, than join pop up window went nuts, changing numbers requested and after timer went super fast, i logged for 2 hours this char but it didnt help
so i asked on global and one guy told me solution, you need to join group go raid and tinker with loot options like changing it initially from free for all to master looter than leave group and this way i could finally manually leave que
hope this help

1 Like

I have tried rlging, grouping, making it a raid, changing loot options several times, but I am still stuck as “active” in RF and can not leave. Are there any other ways to get rid of this bug? (Don’t say “petition” cuz I know that will never be of any help :poop:). Ty in advance! :heart_eyes:

EDIT: When my groupleader signed us up for Kutchemes, I cursed, drank some beer and left group. And tadaaa! Fixed! :partying_face: :beers:

Hi Kirin, hope this helps you or another

Another way: Join a Raid

  • Complete or Leave
  1. Join a group
  2. Group leader makes it a raid
  3. Enter a raid location together (Kyllikki, Vistrix, etc.)
  4. Raid leader changes loot options
  5. Raid leader removes you from raid
  6. Wait for AI to kick you from the raid map

When the AI hasn’t recognized a character leaving raid finder it needs a call that they were removed and should reset as intended.

[Raid finder is buggy when entering and leaving. Sometime the rf window pops and we’re sent in alone before accepting. When that happens, use the door to exit and leave the window up to click accept and join or decline. Perhaps the world boss week and certain raid finders having multiple instances simultaneously contribute to the mix up.]