Cant progress warrior journey or archery journey

Hii im fairly new to the game and after installing some mods my friends recommended i started playing and the warrior journey wont progress past the lock on part of the quest no matter what enemy i use it on and in the archery journey im on the final kill something with a bow quest and it wont continue. Any help would be appreciated <3

The first question is always, did you have that journey step active when you did it?

I have done things a few times with frustration before realizing I was on a different step.

yes i had it active and tried on as many enemies i could find near by, i also tried the remove bracelet method people had been mentioning

Well, I got nuthin. Sorry

Whenever you are looking for troubleshooting advice, and mods are involved, you need to include the modlist.

basements, chest storage size+++, compass, fashionist v4.4.7, pickup+, teleport stone, waystones, WX smoother corruption, Grims wonderbody reupload, grimproductions, thralls are alive, shinboru_productions, shanis stuff, RA: fantasy extension, RA: character customisation, Pippi - user and server management - v3.9.9, Navis extended leveling mod, less building placement restrictions, v7.7.63, improved quality of life 3.4.9, high heels system 3.2.5, gothic architecture, extended leveling - redux, exiled lands extension, evils cabinet 1.0.8 beta, AG - wicked characters, aquilonianfemales, beyond decor, beyond decor: rustic edition, beyond stations, beyond the forge, conspirator_armor, devious desires, emberlight 3.5.3

Yikes. Have to wonder how the server even starts with all that.

Have you target locked the enemy with the stone club you made?

That is one I blew through with no issues. But the system is pretty wonky.

I accidentally punched a chest and got the “Heavy attack” journey step to complete. :smiley:
Still haven’t gotten a “Power shot” to trigger.

1 Like


i managed to partially fix it and progress after i removed some mods but im still currently stuck on progressing the harvesting step for the acolyte journey, im using the correct tool, and collecting from humans but it wont progress

I was having problems with this one as well. I used Yog for it. When i switched to the derketo knife it worked.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.