Stuck on a couple of journey steps

Like the title says, I’m stuck on a few journey steps with a brand new toon.
PC, private modded Exiled Lands

Warrior: Perform a heavy attack
This should be super easy as I typically spam heavy attacks. :slight_smile: However, nothing I do will trigger completing this step.
I’ve used a bone sword, bone daggers, iron short-sword, iron two-handed sword, iron daggers, iron war hammer, steel short sword…
I’ve tried auto-targeting and not. I’ve tried a single heavy hit. A full heavy combo. A light/heavy combo. A heavy/light combo.
I’ve tried people, passive animals, aggressive animals.
I’ve spent 10 attribute points in STR.
I’ve spent 10 attribute points in AGL.
I’ve been in normal mode. I’ve been in admin mode. I have NOT been in creative mode.

Someone suggested that I use the weapon I’d been told to craft in a previous step – bone club – but I didn’t have my original club. I made a new club and used that on people and critters, still no joy.

Thrall Taker: Convert a crafter
No problem at ALL with converting a fighter.
I’m 0/5 with crafters. Two level 1 cooks, a level 1 carpenter, a level 1 blacksmith, and a level 2 alchemist. It’s the same lesser wheel of pain I used for my fighter. I guess I’ll keep collecting and see if there’s a specific thrall type that will trigger this step.

I’ve switched in and out of journey paths and have logged out of the game a few times over the past couple of days. I’m especially perplexed by the Warrior track since I assume that Archer, Armorer, and Tinkerer are locked behind it.

Nope. All separate journeys.

The issue I had was not spending attribute points to unlock journey steps. I got warrior done, was not worth the effort. Black smith is though. Also had no issues with thrall taker. But I can not start tinker. some of the placements I had to empty and replace a couple times; grind silver.

Still working through these but the bugs don’t seem consistent. Seems to have a lot to do with level and what you have unlocked already.

Separate journeys, yes, but the three I listed are currently locked.

I accidentally smacked a storage box while changing its name and the journey step for “heavy attack” completed.

Oh Conan. You so crazy.

Since most of the journey steps are supposed to be done by new players try using stone weapons for the strength step. I used a stone two handed sword and got it completed no problems.