Journey step not completing - Dismantler

Started the Dismantler journey, I crushed a bone in my grinder and completed that step without issue.
Tried putting in plant fibre and it will not complete.
I already had spice in the grinder which I thought may be the cause of the issue (I’ve seen something similar with other journey steps). I have tried removing all spice from the grinder, closing he inventory screen, then adding more plant fibre and removing the resulting spice but it’s still not completing.

Overall I’m good with the new journey system; having to pick the journey and complete the tasks in order does a better job of teaching mechanics to new players than having journey steps randomly complete (though a toggle for experienced players would be good). That said, actually getting the journey steps to complete can be extremely fiddly; I would love to see this addressed in a future update.

Forgot to say I’m playing on a PvE server on PS5.

I might give it a try tomorrow. Let you know what happened… Have a level 60 and 20 on official Siptah server. Hit me up incase I forget @Full_Dave

1 Like

I managed to get around this bug by building a second grinder.
Issues like this kind of negate the whole philosophy of redesigning the Journey system to better serve new players so hopefully this is something that can be addressed/fixed in a future patch.

1 Like

Let’s hope so

Not sure if it’s a factor in your case or not, but the journey system is very particular on HOW you complete a journey step. Sometimes, you have to double click, not drag and drop or use shift to specify amount. Other times (particularly with thralls), you HAVE to drag and drop because they don’t go in the right slot if you double click.

Thrall taker also requires using a 1-slot wheel of pain; between taking my very first thrall and then getting to the crafter thrall step, I had upgraded my wheel of pain to a 4-person wheel and step would not complete for converting. Thanks to @Xevyr’s debug mod, I was able to have my admin push that one for me, rather than making another single slot wheel of pain and capturing another crafter thrall just to satisfy the very arbitrary conditions.

1 Like

Note. If you journey step asks for some specific component. It can’t already be in the bench, or on your person. As in the grinder. it needs to be empty and you have no ground mats on you.

Ya, these need a lot of work. They are way to finicky. Or some wont count something you have done, you can’t easily do again.

I’m stuck on part 2 of the religion one. I’d already upgraded my alter to it’s final stage, and the journey step wont count it. So I’ll have to start and upgrade another I guess.

Yeah, this stuff is frustrating. I like the ones where they say “create or access” in regards to upgraded benches and things. Why spend the materials, especially in the case of altars when you already did the thing? I’m pretty sure you do play on officials, otherwise I would highly recommend the Journey Debug mod.

Playing on PS5 so no mods for me I’m afraid.
I agree, the journey steps that state ‘create or access’ have all worked every time for me.
I’m now stuck on the Beastmaster journey; feed your pet - have tried feeding multiple pets, removing the food, etc. Nothing seems to work, this is very frustrating!

Oh, this one is horrible. Everyone says to click ‘use’ on the food once it’s in the pet’s inventory to get them to use it. But it seems to work sporadically.

  • Rocknose: no ‘use’ option on stones
  • Panther: ‘use’ in their inventory resulted in my character eating raw meat and getting food poisoning
  • Herbivore pet (I think elephant): ‘use’ berries and it counted as the pet eating it

Not sure what the difference was between the panther and elephant but I do agree it’s incredibly annoying!

Fixed this one too - I just put in something that’s not on their preferred food list - was then able to hit ‘use’ in their inventory as they don’t eat it automatically.
Again, unnecessarily obtuse - just have it trigger when they eat food on their own.