My Journey step is not updating


#1

Game mode: Online
Problem: Bug
Region: EU
Server 1050


My Journey step for equipping light armor is not updating even though I have full set equipped. Light turban, chestpiece etc. every other step goes through without any issue


#2

Same here. I am wearing full light for some time now, even wore medium and then went back and tried around a bit to get it to update, but so far nothing works. Journey step stays unfulfilled.
Any workaround until it’s fixed?


#3

The sandstorm mask works for some people. But not everyone.
I’m not aware of any other workarounds.


#4

This is a known and annoying bug with many servers. I too have not found a fix for it, but running my own server I found we didn’t suffer this issue?!

For now, you could use this list to identify what is needed in the next chapter. You’ll still get the points. Another guide would be to use the 3 Journey tips at the top right of your screen to allow you to continue.

Spoiler Alert in this link. If you’d prefer to learn the Journey steps by yourself, don’t click the link.


#5