Journey Steps Bugged

Game mode: [Offline | Singleplayer]
Problem: [Bug | Misc]
Region: [Here]

*Possible Spoilers. There is currently several bugged or otherwise uncompletable journey steps which I have run across during the game. I find this a bit frustrating, as in some ways the journey is the closest thing we have to a main questline. The offending steps are:

  1. Ch8, Step 7: Discover all of the Lemurian lorestones. Is not awarded when completed.

  2. Ch9, Step 10: Discover all of the Giant-king obelisks. Is also not awarded when completed.

  3. Ch10, Step 8: Explore the entire exiled lands. Similar to the fiest two. It seems that this works for some people but not others.

  4. Ch10, Step 9: Defeat the Mummy of the Ring. This guy doesnt seem to be in the game for some odd reason. Such a shame, as not only does he sound really cool, but one last epic end of game boss battle before removing the bracelet would have made the ending really memorable.

Could the devs possibly give us an update on any possible fixes for these which may be in the works? Especially the the last one; Im intrigued!

Steps on how to reproduce issue:

  1. Play Conan Exiles
  2. Attempt to complete all of the Journey Steps
  3. Discover that said Journey Steps can not be completed
  4. Ask the devs politely to assist

Started a new character with my friend on pvp, got disconnectrd once and now my journey is reset and i cant gain any journey milestones no more… Ive tried relogging, closed the game and reopened… Didnt help at all…

There has been numerous posts on the forums regarding Journey Steps not working in the past, especially for the Light armour and Lemurian lorestones Journey Steps. However I have not heard if they are currently being worked on or not. Funcom was kind enough to fix the ‘Equip a piece of light armour’ Journey Step, can we please fix the other ones now too…? Would it be possible to have this issue added to the trello board, so that we can put it to a vote and gauge interest? I dont even mind if it goes in the backlog. I am sure I speak for many of us when I say it would be a welcomed relief to know that it being addressed. Many thanks.

1 Like

Thats definately not cool. Im curious, did you have difficulty completing any of the bugged journey steps I outlined prior to when this happened?

Hey there!

Thank you for letting us know! We have added these issues to our list of nasty bugs to squash. If there is any other steps you cannot complete please let us know as well. We really appreciate this level of conciseness!


1 Like

Hey thats great, thanks a whole heap for the reply Ignasis. No problem at all, and I will indeed let you all know if I discover any others. May I push the envelope just a bit further with a quick question? So…does this mean that the Mummy of the Ring will eventually be making his way into the game? […crosses fingers, leans foward with excitment and anticipation…]

Hey again,

Well, regarding the Mummy of the Ring, I can only say that [classified], but also [redacted].
Hope to be of any help!


1 Like

Ignasis that is diabolical! Ok then, I will assume an optimist viewpoint in this case, as I see no need to classify or redact something which will never exist :wink:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.