Attn PC Players, Testers and the Tech Savvy...Please Help..!?


I am sending you all this message because I am currently overseeing an issue, and I feel it would be wise to consult more technically minded PC players such as yourselves for some information, and advice on how best to approach this. And to request your help where relevant…

I yesterday recieved a message from a Funcom CM, as a follow up to a bug report I made, concerning Four Bugged Journey Steps. If you are interested in reading more for yourself, you can find the original posts in the ps4 section titled ‘Journey Steps Bugged’ here:
But in a nutshell they are:

  1. Ch8, Step 7: Discover all of the Lemurian lorestones. Is not awarded when completed.

  2. Ch9, Step 10: Discover all of the Giant-king obelisks. Is also not awarded when completed.

  3. Ch10, Step 8: Explore the entire exiled lands. Similar to the first two. It seems that this works for some people but not others.

  4. Ch10, Step 9: Defeat the Mummy of the Ring. This guy doesnt seem to be in the game for some reason. He doesnt even appear to be in the Admin Panel! Such a shame, as not only does he sound really cool, but this one last epic, end of game boss battle before removing the bracelet would have been really memorable.

Unfortunately, the rep said that the QA team were unable to replicate them. I am now going to try and do so myself over the course of the weekend. However, I am curious if you yourselves have had any difficulty completing the said steps, and if you know if there is anything (technically) amiss with them?

The reason Im approaching you all as a community, is because you are obviously quite knowledeable on a technical level, and also because PC players have access to a plethora of other features which we console players do not. For example, spawn codes, console commands, dev kits, game file info, etc. I was informed that because they arent considered game breaking, they will likely be closed unless I can give them something more specific to work with. I feel that the Journey Steps are kind of the closest thing we as players have to a ‘main questline’, so I am trying to get them all functional. Therefore, I am beckoning you all to provide any information or testing which you can spare. I love this game with a passion and yearn to see it be the best it possibly can be, and for its ‘storyline’ to be intact and fully functional.

So to our PC playerbase out there, if there is ANYTHING, no matter how seemingly small, or helpful at all which you could do or tell me which may aid this cause, or shed more light on this issue please do. I mean were missing our ‘end of game boss’ here, who has a Keystone piece! In a manner of speaking anyway. Is there anything you all can tell me? I thankyou all kindly for any help.


Update regarding-

  1. Ch8, Step 7: Discover all of the Lemurian Lorestones.

Just posting a quick update on this issue. Having re-tested the first item on the list numerous times over, and over time, I am pleased to report that it finally logged as completed for me today. This resonates with the reports of other players in the past, but especially a recent one by Resurrected who successfully completed this, but not ‘Discover all of the Giantking Obelisks’. Here are the details:
I am absolutely certain that this was not just a case of player error, as I have completed ALL items on the same list numerous times over! It is possible that one of the past patches provided either an intended or coincidental passive fix for this one.

In summary: It appears that this one is temperamental to the order of completion. However, it IS possible to complete it under the right conditions. Should anyone require further details, I am happy to supply whatever I can.

I assume there actually not all discovery points, because some dungeons are in development, so some dungeon entrances should be added to the map.
If everything could be discovered at the current time, it would mean that there will be more addition on the map, and it would be very sad.
Months ago I tried a mod that unlock all the discovery points when you log into the game, and there was a location in the lower left corner of the map. A discovery point named “None”. A point that you can’t go because it’s far behind the wall of the death. So I think this point has been placed here to be sure that ppl dont get the Journey Steps before Devs want it.

Again I think Devs keep this boss for a next dungeon, I dont worry too much about it.

For the other steps I need to dig more into the Devkit to see if I can find something.


In the Devkit, 13 locations trigger the Lemurian lorestones journey step. Some ppl can complete it, some cant. So the achievement is bugged, I cant figure why. Maybe a blueprint bug, trigger box bug. I dont know.

If you watch this video there are 29 Giant king Obelisks. But in the devkit, only 23 locations trigger the journey step. So I assume 6 obelisks are not checked as JourneyLoreType : GiantKingObelisk.


Great posting.
FC’s ‘error’ appears to have only been to fully set up the Accomplishment screen with all current and future goals instead of adding to it as they add patches/updates/dlcs/etc. As Alex02 says, some of these will unlock in the future.
I cannot remember the exact accomplishment, but there was one relating to the Tower of Bats a long way back. After one of the updates in 2018 I got an accomplishment as I logged in. Apparently it was triggered by a base I’d put up there before the story stuff was added.

That’s bit the thing, the patch may or may not fix or change some imputs, and so we would have to test it all over at each new patch release. That’s also the case with lot other stuff, old bugs coming back ever if fixed several times, and so on.

There may also be a difference between singleplayer and online play.
Happened to me in different games having different results, some journey was triggered, then not, hard to say what may it work, or what is missed.

There are points not able to be discovered because they are outside the playable area. The two points called “none”. One is the starting area where the launch video does trigger, the Conan scene.

There was some mod fixing it, so these missing spots triggered, not sure if it’s still around.
Like said, i’m not running after the journey-steps so much this time, did it so often. :wink:

1 Like

Wait, what? The Mummy in the Ring it’s supposed to not be in-game? But I just fought it last weekend when I went there to complete the Arena? He surprised me on the way back when I was fighting some of the random skeletons that are in the middle canal-type area… I’m confused now :confused:

EDIT: And he was a tough cookie too… I’d say that it took more effort to kill him than the Undead Dragon! :smile:

1 Like

The Mummy in the Arena (or unnamed City) is part of my mod stuff. :yum:


Nice! I suspected as much <3

1 Like

Hey Alex02. First of let me just say thankyou for coming along and offering your input and skillset on this matter. These are OUTSTANDING posts, rich with detail. Your hard work was appreciated. Ok I have re-tested all but one of these bugs again, and felt I should contribute what if anything useful I have discovered to the information stockpile. Now regarding the following two:

  1. Ch8, Step7: Discover all of the Lemurian Lorestones.

Ok I went and visited all of the locations listed on the picture below in chronological order. An explanation key is listed on the page. Please excuse the messy handwriting.

As stated earlier, this finally logged as completed for me, on what was approximately the fourth attempt. I also found there were 13 locations. None of the stones were visibly irregular. Ironically it said ‘completed’ on the first one! A good outcome, but a potential pain from a testing point of view. I know for certain I had activated it in the past too, as I go there to harvest bulk amounts of yellow lotus. Maybe a previous patch corrected it?!? As you said Alex, it seems some people can complete this but not others. Thanks Alex, I will be drawing Funcoms attention to your findings on it. If anyone else is having trouble with it, try mixing up the sequence, or try the one on Sanctuary Ruins first as a stab in the dark. Then again after all others are completed.

  1. Ch9, Step 10: Discover all of the Giant-King Obelisks.

Ok this is where it gets a little bit strange in terms of the findings. The source I tested with was a map from Snowhawk Clan (great interactive map too guys!) Which can be viewed here:
Based on this source, and assuming I havent made any errors, there is actually a total of 35 of these Giant-King lorestones. Although it should be noted that some of them, such as the first 6 on the list below, are exactly the same eg- in the starting area, but appear in multiple locations. I completed all 35 in the order on the pictures below.

So it is quite possible that as you said, only 23 (or not all of them trigger this Journey Step. I also noted some are different colours too. Probably not important, but just thought I would put it out there. Only one displayed (very minor) irregularities. This still has not logged as completed. Quite possibly temperamental in terms of order. This one is DEFINATELY bugged, as also posted here recently. Journey stones ( giant kings)
I should also noted that I also interacted with each lorestone on both sides where possible, and let them finish speaking entirely before progressing to the next. Finally, probably irrelevant, but I re-interacted with all regular maproom obelisks to eliminate variables. Do you suspect it may be the same problems as those causing the Lemurian Loretone bugs Alex02? While Im not sure just how many there actually are and which ones count, I hope Funcom can reproduce this.

Has anyone managed to complete this? Whether you have or not, we encourage you to share ANY observations.


Ok now my observations regarding the other two bugged Journey Steps. First off:

Ch10, Step 9: Defeat the Mummy of the Ring.

I really hope that youre right on this on Alex02 and he does make an appearance at a later date. A cryptic final reply a CM sent me in the following original thread may or may not answer this:
However, it never ceases to amaze me just how little attention this bosses absence gets, and more so how it doesnt bother others (Im not attacking you here Alex, I promise, it is just a broader observation). Case in point, I couldnt find a single image of him online, including our Gamepedia site. I find that it REALLY bothers me, way more than the other bugged Journey Steps. He is our END OF GAME BOSS people, and holds 1 of the 7 story artifacts!! For example, if I went to finish Skyrim Spoilers, got to Sovengarde to battle Alduin, then found out hes not in the game when he should be, and I only have to talk to Tsun to finish it, I would be incredibly grumpy! But anyway onto my test findings.

As previously stated, I couldnt even find an image of him on the net. However, I eventually hit a breakthrough when I found him on this ‘Just Horse’ youtube video, and in a few random comments. He is pictured at around the 5:00 mark. For any who dont want to see what he looks like, I urge you to leave this thread now!

Basically this who we are talking about:


Looks cool hey, like a horrific Anubis. Based on the datas, I had reason to suspect that he doesnt spawn at the Chaosmouth Alter as the Journey Step would have us believe, but rather in the Unnamed City at the ‘Citadel of the Triumvirate’ (makes sense considering his conjurer Thoth-Amon, stole the Serpent Ring from there), or as a purge boss. So I built a secondary home in the Unnamed City (God help me). I then travelled to Chaosmouth Alter and the Citadel multple times over under four circumstances:

  1. with the artifacts back at home, none on me
  2. with the six artifacts all on me, no keystone
  3. with the keystone on me, but not the six artifacts
  4. with the six artifacts AND the keystone on me

Prolonged periods of time were spent wandering around the said areas and other general ones. However, he still simply would not spawn for some unknown reason! In a last ditch effort, I reached out to ‘Just Horse’ who told me he spawned him manually using a seemingly deceptive admin panel code titled: Wildlife_Storyboss. I tested this, and was able to spawn him with it, so he IS actually in the game currently.

This has led me to one of two conclusions. Either:

  1. he is indeed coming in the form of additional content at a later date (God I hope so!) or…
  2. there is a bug which is blocking or preventing him from spawning as he should

Hopefully Funcom can clarify this? For the record, if it is indeed number 1, sorry to spoil it. My goal here was to investigate bugs NOT generate leaks; edit sensitive information if you deem it neccessary.

1 Like

Finally, regarding the following step:

Ch10, Step 8: Explore the entire Exiled Lands.

As mentioned previously, it seems to have worked for some people but not others. Perhaps some locations are not ‘logging’ or ‘tagged’ correctly as found when they are discovered!? Or maybe some of us (possibly myself too) have been going off incomplete sources which are missing a few locations.

This is quite possible again Alex02! And I really hope you are right on this one. I would also really like to see another biome or two added to the map (Ive actually got an idea for one I will be presenting for suggestion soon), and would similarly be saddened if there are no further additions planned. So it is indeed also possible that it cant be completed because Funcom keeps moving the goal posts (ie- more locations being added). I have admined beyond the cursed wall a few times, but am reluctant to go too far in case my game ‘freaks out’ and becomes unplayable on me. It looks pretty ordinary from what Ive seen, but Funcom could change these areas as they see fit. I like to think of them as ‘potential new development sites’ to use construction terms.

Ok, although I discovered a large amount of locations on my testing. Unfortunately, I simply ran out of time before I could try all of the locations on my list. Therefore, I am not willing to share incomplete results at this time. I will resume testing as soon as I can (probably next weekend). I will update this post as soon as I know anything else.

This boss is definitely planned in the game, because the mob Blueprint exists in the Devkit:

He’s not really an end game boss, because he’s weaker than the Barrow King (low health : 2142 HP, and weak weapon : stygian spear).

This mob is also listed into the SpawnDataTable like any other monsters:

That’s why he appear in the the admin panel and you can spawns him into the game as admin, his name is Wildlife_Storyboss

Mummy have his Row into the WeightedSpawnTableRow:

This table give the spawn rate data to the monsters.

So everything makes me think this boss should spawns into the game. I dont know if something prevent him to spawn, or if it’s intentional. Like maybe Devs disable his spawn point into the map because they will put it somewhere else.

Note :
In my mod, to make him spawns I just replaced the giant snake mob by the Mummy in the SpawnTable in order to make him spawn into the Arena or the Unnamed City. Because there is no interest to fight the giant snakes.

Oh man, yeah! Totally agreed… I hated those giant sneks :unamused:

This is quite interesting, what lies beyond the boundaries. Ive had a few short wanders beyond the cursed wall, but as I said Im not game to go toooo close to the edge incase in ruins my game somehow. Ive already noticed that doing so removes my notifications, eg- bleeding, regenerating, incresed strength, losing corruption, etc. Fortunately all is back to normal whenever I play next.

Holy mackrel, the undead dragon was tough too. Especially as I play singleplayer offline. And I agree 100% on the Snake world bosses. Theyre so quick and unrelenting.

I get what what you are saying Alex02. Its definately a bit of a mystery. Hopefully Funcom has read this, and all will soon be set right. I will also send them a link to, just to be sure. Again I appreciate your help with testing.

I forgot peoples, I should have added that there is technically a fifth bugged Journey Step which I forgot about long ago, as it is a more benign one.

5) Ch10, Step 7: Equip an Epic Armour Set.

This one can be completed by simply equipping a set of regular Vanir Armour, as opposed to an Exiles Epics set. This is a relatively harmless bug, as it does not require an element of chance or a bug fix to complete it. However, I felt I should just put it out there for the record.