Can't use any currency to purchase items in game

I have run into a bug along with a few people on my server in which we can’t use any of the gold / silver / heads / blood stone or the orib currency to purchase in game items from the vendors.

1 Like

Have exactly the same problem on my private server. :frowning:

Yeah. Completed the new dungeon and got Kurak’s severed head and couldn’t turn it in. Clicked the button several times at the trader for the Grand Ophidian pack and it didn’t do anything. Kurak’s head is still in my inventory.

Hello everyone!

Thank you for reporting this issue to us, but please make sure to use the given Bug Report Template.

This template has most of the information we need to start investigating and will make the process a lot quicker for everyone :smile:

You can find it here: NEW Bug Report Template

Thanks in advance!

1 Like

The information you filled out should now be listed below. :point_down:
Please copy this info and paste it into a new report. Thank you!

Basic Info:

Platform: Steam
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvE-Conflict
Map: Exiled Lands
Server Name: 1972
Mods: =MODS=

Bug Description:

Unable to use currencies for certain items in game. Obo and severed head unable to be used mainly.

Bug Reproduction:

played the game

Greetings Exiles,

Can you, please, also share a screenshot of this happening?

are you serious? i cant share a screenshot because that wont prove anything lol. I’m standing in front of the vendors… spam clicking and nothing is being purchased… how can a screenshot prove that lol

1 Like

I have same issue. Cannot use Obolus /Blood Crystal currencies to purchase anything from vendors at spire and caravans.


Thank you for bringing our attention to this!

I’ve passed this information to the rest of the team so we can investigate.

1 Like

Basic Info:

Platform: Steam
Issue Type: Gameplay
Game Mode: Online Private
Server Type: PvE
Map: Exiled Lands
Server Name: Synergy/Relaunch3-6/Events
Mods: None

Bug Description:

Merchants at Mek-Kamoses’s Spire. Unable to purchase from any of the merchants including caravans. The option lights up but when I click on it nothing happens. Tried spending blood crystals on golem part and tried spending obolus coins at Spire and Caravans, tried selling severed head at Spire. None will work. ALSO multiple server crashes and dc’s.

You got to kill sorcerers and when zombies start attacking you. You must find corruption stones and destroy them…


Bambere is right, during the fog you need to find 3 pillars oozing corruption and attack them til they crumble. They are arranged in a triangle so run near the outer edges and you’ll find them. You can make up for lost time from the golum phase in the fog by trying to get the pillars down as quick as possible because it insta kills the remaining zombies once all 3 are down.

1 Like

Thank you :slight_smile: But it won’t let me kill the sorcs. I hit them and nothing happens and I had tried hitting the stones…they would not break (maybe cause I can’t kill Sorcs, not sure)

I have the same problem, merchants in Sepermeru do not work.

yep can confirm still can not purchase items from the blood crystal vendors or any of the orbos vendors still

Having the same issue, the only vendor that seems to be working is the thrall vendor.

I am unable to purchase rocknose pets even when I have gold in my inventory. I have 60 gold coins and am able to click the button however nothing is purchased. I get no rocknose egg and my gold coins do not deplete from clicking on the button.

I am also unable to purchase Spider Egg-sac from Owen the Beautiful in exactly the same fashion.

We’re seeing this on Official #1735 as well. Headhunter wagons show the button as active, for a purchase, but clicking it does nothing. No coin lost, no item received. I had this happen at the camel vender, and even the Archivist in the Unnamed City when I went to get the oil recipe.

If I logged out/in right near the vendor, I could purchase again. But some time later, something breaks and I can no longer purchase from any vendor.

1 Like

There may be a work around…

The workaround that was suggested was to log out and back in while standing in front of the vendor, then try again - but this solution only works …very rarely, for me.

My friend did this right after completing Mek’s dungeon and after logging out and back in, he was able to trade in the head.

So now, I have after many tries, been able to make a couple purchases of the new Mad Prophet armor pieces with Obulus. Each piece had taken several to dozens of tries… I’m just not sure what changed, and each time I try to replicate a successful purchase at the next armor piece location all attempts fail even when duplicating the same actions that worked before. Even after dozens of tries now.

So I guess to sum up… Purchases are only mostly dead. And mostly dead is, a little bit alive?

1 Like

I’m having the same issue on my private server. Can’t purchase from any vendors.