ConanBattlePass:Error

Basic Info:

Platform: Steam
Issue Type: Other
Game Mode: Online Private
Server Type: PvP
Map: Exiled Lands
Server Name: holidayz extreme perfomance PVP server 24/7
Mods: None


Bug Description:

The Server Log is spaming this Error. The server runs but it hinders perfomance:
ConanBattlePass:Error: Failed to Update BattlePass Challenge. Visit. Invalid player character reference.
ConanBattlePass:Error: Failed to Update BattlePass Challenge. Invalid player controller reference.


Bug Reproduction:

Fresh install of Windows Server 2022. Fresh DedicatedServerLauncher 1.7.8 install. Created the Server. Changed few settings but only in the GUI of DedicatedServerlauncher. No Mods. Just a normal server.


1 Like

Greetings @MorphZ ,

Due to the fact that your issue is related to a private server, we would advise you to join the Admins United Discord (also referred on: Admins United: Conan - Discord for Server Admins! ) as this discord includes other admins with the experience to better assist you.

Continue conquering the lands!

I dug a little deeper by now.

The issue is related to Funcom Services and the BattlePass Synchronization across Servers. It has nothing to do with the private server itself.

The first user created on all servers has the character ID 29. (game.db file)

Because I wiped my character after setting up the in-game server configuration - I got the ID 30.

It’s also a good idea to auto increment the ID’s in case a player deletes their character. BUT:

The next user that joined the server after me got the ID 29… again. The same ID that my old character had before I deleted it. Why wouldn’t it just go to 31 (or whatever number - just not 29!)?

I am 99% sure that this is the problem. Somehow Funcom decided it would be a good idea to include this character ID in the battlepass DB instead of relying on the Steam IDs…

Now the Funcom BattlePass Service expects ID 29 to be me. but it isn’t. hence the errors in the log.

I cannot correct it myself - I could - potentially - switch the character IDs for 30 and 29 on all tables in the game.db file. But then again the ID wouldn’t align for the User that has the ID 29 right now. And I’d get the same error. But for another character.

I don’t expect you to fix this issue. But it would be nice to have the theory confirmed so nobody wastes time trying to figure the solution.

Kind regards

Unlikely. The game communicates with Funcom Live Services for that stuff, and those use your FLS account ID, which gets generated the first time you log into FLS. The FLS account is associated with your Steam ID.

This sounds like an issue in the game itself.

That is comforting news. However, the private server does communiate with Funcom Live Services for the BattlePass. I can’t see a way to solve this issue on my end other than to learn to live with it.

I couldn’t find another error in the db file other than the reused ID. The Characters also aren’t linked to a Steam ID in the db itself. If anyone knows more about that, let me know!

Deleting a Character is a Mechanic included in the game. The error must be related to that event. After all it’s a mod free server with the original configuration files.

I have other servers that do not have this error. But I’m also not sure if anyone ever deleted a character on those.

seemed to have a similar issue and fixed it with a mod that forces people to choose a character when they join the server.

But I haven’t found any traces of my old deleted character in the db.

And I’m not going to install a mod. I also won’t wipe. It is what it is.

2 Likes

The characters are linked to accounts. The playerId column in the characters table is a foreign key (although not explicitly configured as such) into the account table, whose primary key is id. In the account table, the column user contains the FLS account ID.

If you don’t know your FLS account ID, you can look it up in your Game.ini file, in the [FuncomLiveServices] section. There should be a CachedUsers entry in there with a TitleDisplayName that you recognize as your own. The MasterAccountId in that entry is the FLS account ID.

I’m not sure if that will help you solve the problem, but I thought I would share what I know.

1 Like

My initial theory was flawed.

I still don’t have a solution to the error beyond the mod installation mentioned earlier. I haven’t yet confirmed CodeMage’s information, but it looks super promising to trace the roots of it.

Since my post a few days ago, the error appeared on my experimental server too, disproving the theory about it occurring after deleting a character.

The issue might be related to the DedicatedServerLauncher itself, the Server Image on Steam, or possibly the Funcom Live Services. Yes, pretty much everything.

I’ll keep you updated.