Conan's most annoying things the community hate

The only things in CE that actually annoys me is that sloping inverted walls are still to this day, years later, a complete and total nightmare that almost never work and the wonkiness of spider hitboxes with certain weapons/attacks.

2 Likes

I agree, the buttons are too close to each other BUT it does offer you an “Are you sure?” option.

I have never had a problem teleporting with a thrall. So it’s probably an issue with your machine’s capabilities. Console will have issues with Conan because it’s just too powerful for PS4 and Xbox. It’s a FAAAR better play on PS5.

Well, if you’re in a sandstorm, it’s supposed to be blinding. Having been through real-life ones when in Gulf War, you can’t see ANYTHING and it HURTS like hell. Heck, it strips paint off of items. lol.

The only bench that has done this is the Casting Bench. However, if you craft one, then select craft all, it will craft as many as possible. You don’t need multiple casts.

You’re on a previous-gen console. It doesn’t have ray tracing so you won’t see the big glowing body loot.

That’s a server setting. Find a different server.

LOL, Wow…lazy much? LOL. When you get out of the Shower are your clothes automatically on? Come on man, when you pick up a pile of material, you should have to search through it to find the items you want. If you’re in a fight, grab your loot and get away from the fight. It doesn’t take long to put on your gear.

Are you talking about NPC’s? If so, you’d have to be pretty low level to get killed by them at the Obs…If they’re live enemies then the reason is…because YOU’RE there. If I’m your enemy, I want to kill you there. If enemies are on, I’d recommend avoiding Obs. Otherwise, there are plenty of other ways to travel and if you learn the map, I can get virtually anywhere in no time with a horse.

Ha…I agree with this one. I’ve jumped on my horse many times at the worst times.

Hasn’t happened to me in a loooong time. However, the solution is simple. Place the items in your thrall or carry a chest with you when you know you’re going to transfer items.

So you can’t HAVE compact bases and get the perks of those benches. If you want to have a compact base, use the basic or improved versions which are still available.

Simple…So people can’t miraculously spam heal anymore AND because when you need to heal, you should have to actually bandage your wounds or drink a potion. Don’t want to die in a fight? Get better at fighting OR exit the fight to heal.

When was the last time you’ve ever seen a water well with fish in it? You don’t because…They don’t. If they did, you couldn’t drink the water. So it makes sense that there would be no fish in a well to catch. As for baiting traps, fish traps need to be baited to attract fish into the traps. Baiting them is super simple if you get your routine down. We just leave compost in the bin and it just keeps creating grubs. Simple.

However, if you want to make oil, it’s best to make it in the Alchemy Bench with bark.

Honestly, the only thing that bothers me about Conan is the offline raiding and the building system. Specifically, how you get no room for error when placing a piece down. If you do, you lose most of your materials.

I would also like to see an improved fighting system…Something like For Honor’s would be amazing.

Because that would be stupid for an official server setting. You’d literally just go out of your base with 50 encumbrance, farm stuff and remove bracelet. Wake up in your bed with all your farm.

2 Likes

Not really the most annoying. But I’d like to see some of my thrall’s become cavalry.

Well, sounds like we’ve found a solution to some players complaining that nights are too dark and wieldable light sources are bothersome.

Step 1. Go to the place that is too dark.
Step 2. Remove bracelet.
Step 3. Return to the no-longer-too-dark place.

3 Likes

Yes, it is. However, in Conan Exiles, “the gamma goes pure white and you can’t see anything”* has been a known issue for a year or so, it’s not working as intended.
If you would like a brighter variant -or any variant, in fact- of the sandstorm, feel free to suggest this in a seperate thread.

*except in some cases, some horridly contrasted textures.


See below reply:

And this other issue, being missing visuals/sound, which began around the same time:


Also cc: @ConanBoDk, who I encourage to post their videos of the sandstorm(s) in a seperate thread. If you aren’t able to post/link a video in your post, get the essential part of the link, i.e. for YouTube, the part usually behind https://www.youtube.com/watch?v= in the URL -you can copy and paste this-. Otherwise, you’ll need to be a little more active on the forums to get this permission (see forum guidelines for requirements).

For context: I play on PC, so anything I say about the current state of the game might not be true for consoles, since they’re still on version 2.3 and we’re on version 2.4 now.

When you teleport while dragging a thrall, if your loading screen ends fast enough, you can see the thrall rushing towards you from very far away and then disappear. The key thing to note is that as long as your toon is still holding his or her hand up with the bindings equipped, you’re still dragging the thrall.

So whatever you do, do not unequip the bindings. If you do, you might get lucky and be able to find the thrall lying unconscious near the place where you unequipped the bindings, after a combination of relogging, running out of render distance, etc. However, most of the time it will be lost.

Bear in mind that even though mounting and dismounting while dragging now works without unequipping the bindings, that’s not necessarily the case after a teleport, so avoid doing that too.

This has been the case for more than a year now. It’s annoying, but it’s just visuals. It has no impact on gameplay. The most popular theory is that this is the sandstorm that blows in during the intro after creating a character, and for some reason it gets triggered on login.

Uuuuuse the maaaaap, Luuuuuke.

Let’s find a private server with that setting, there’s plenty of those. The rest of us like a little challenge :wink:

If you’re on PC, that works now. You just look at your corpse until the inventory popup is displayed, and then you press whatever your “Loot All” binding is. I have read reports that this does not work if you actually open the inventory and press the “Take All” button in the UI, but I haven’t tested it.

If you’re on consoles, you should have that feature on Thursday :slight_smile:

It’s even worse on PVE-C servers, where other players can (and sometimes will) camp by the obelisks (or Siptah vaults or any other place with a loading screen) and gank people who can’t even see what’s going on. It’s the worst on PVP servers, where players don’t even have to hang around, they can just place a few thralls.

The problem is not that there are enemies near the obelisks. The problem is that the game places your toon at its destination while you’re still inside the loading screen. Funcom needs to fix this, but the only way it will happen is if we don’t let them forget :wink:

This one bugs me too. The real problem here is that literally all other followers open their inventory with the tap of the “Interact” binding. So the game trains you to do it like that, it even lets you do it like that with a mount that doesn’t have a saddle, and then, once it’s saddled, it goes “ha ha! dumbass!” when you do that and puts you in the saddle :laughing:

But still, it’s a minor annoyance compared to some other things.

If your friend can’t see the bag but you can, they should relog. If neither of you can see the bag, then it might be lost, but I’ve never actually had this happen to me or anyone I ever played with.

That’s the idea. Think of it as T1, T2, and T3. So, for example, the furnace is T1, the improved furnace is T2, and the big-ass furnaces are T3. The T3 versions are meant to force you to deal with the tradeoff: either you conserve space but pay more in terms of material cost or crafting speed, or you gain those benefits but sacrifice the space in your base.

You’re using them wrong. Bandages are not meant to be used in combat situations. That’s what potions are for. Bandages are supposed to be used after the battle, when you’re safe. And before you ask what the point of that is, let’s take a look at the alternatives:

  • You could use potions after battle, but they are heavier (almost 6x) and a lot more expensive.
  • You could rely on food for healing after battle, but then you have to be extra-careful not to take any damage whatsoever, not even 1 hp from a short fall you misjudged.

Yeah, I gotta agree with that. I understand that they wanted to get rid of passive resource generation for something as valuable as oil. And I also understand that they wanted to get rid of the fish trap spam. They achieved the former. The latter, though, backfired spectacularly. Instead of 20 fish traps, now you get 20 fish traps and 10+ compost heaps. Or at least, that’s how it used to be for a while, until they lowered the requirement for the oil recipe at the alchemy bench, from T4 down to T3 alchemist.

I imagine they will eventually revisit fishing. And cooking. But they can’t do everything at once, especially now while they’re preparing the official Siptah launch. Sometimes the only thing they can do is look at what they did, realize they goofed up, and fix it later when there’s time. :man_shrugging:

My number one pet peeve right now are the dragons. I’m thinking of opening a bug report about them.

Look, I understand dragons are supposed to be dangerous. They’re not supposed to be easy to kill. But someone went overboard here. They rotate faster than a freaking fidget spinner. To make it worse, many of their attacks hit targets in a cone much wider than it looks, certainly wider than it used to be before. And to add insult to injury, they won’t attack you until you’re in a much narrower cone, they’ll just keep rotating and rotating.

I’m still trying to figure out a decent strategy for soloing dragons and hatchlings. So far, I’ve only managed to figure it out for green hatchlings, because they mostly try to ram you, which is the only dragon attack that isn’t completely FUBARed.

And yeah, I know that an easy strategy for defeating dragons and hatchlings is “bring a follower”. But that’s not my idea of fun. For me, followers are a way to speed things up. They’re supposed to be my sidekicks, not the other way around.

3 Likes

Yeah, but I can deal with that normally. The problem is how that interacts with other things I said. Basically, the dragon will keep rotating until you’re in a position where you have no possibility of evading its attack except (maybe) through a dodge roll. The cone they use to trigger the attack is much narrower than the cone they use to determine if the attack hit you, and the attacks have a very short windup that doesn’t allow you to evade at all.

I noticed something similar to that with a corrupted croc - though thankfully that one seems to not use that really quick non-telegraphed attack as much as normal ones do (which is a relief as the time I did get hit with it it took about 70% of my hp away).

1 Like

I don’t post them yet. I have to Copy it and check how to share. But I can confirm the brightness sandstorm only happens in the first 20 minutes of being online. The invisible sandstorm happens after hours and it seams to be randomly becouse between invisible sandstorms there where normal sandstorms.
I collected some videos and I will try to share it here next weekend.

1 Like

I take a 5-year break from tennis, no problem, maybe sore shoulder. Need to reduce screen time so I’m off Twitter 3 months? Easy as pie getting going again.

Take time off Conan and you’re like Rip Van Winkle wakin to new-age rocknoses and crashed oil economies. So many changes. It’s an annoyance a lot of players talk about but to me it’s a good annoyance. It can be a substantive bar to resumption of play, however, and if it weren’t for me bud @Cauthey I’d still be standing over the armorer bench muttering about Flawless sets.

Welcome back! You were missed around here :slight_smile:

1 Like

I agree, The Thrall is knocked out, and even if you touch thier bracelet to the stone… I just assumed you had to do it yourself. XD

I get this on Ps4, one click… nothing
2nd click, it works. I think its just system lag.

Death light, I have my Nights set to Dark… So it glows pretty well, Issue for me on Ps4, is it’ll be half in ground, or It’ll move 40m to another spot, And i have to hunt it down Hill or 2 over. (In area I never walked or passed)

Large workstations… Not even “small homes” and trying hide… Consoles can only handle so many objects. Larger benches just added to everyone base sizes…(which I had pretty planned out.)

I got my home down to point, were I turned Camera, stuff wouldnt be in LOD form, and still be loaded in. New workbenches just add to issue we wanted FIXed… but they just add on to it.

I have yet to screw up break bond…

Only 1 I screw up is my inventory quickslot South and Southwest Slots, I go to use SW for pickaxe, and I’ll eat my food in South slot.

Most of my hates… I’ve been mumbling them for years, and nothing gonna change. One day I’ll get my nudey thralls back. Or maybe they’ll get rid of ***** Turban and fugly gloves…

AI 99% going for my Horse or Pet… 6 baddies can charge me, I head out meet them… and they all run past me to stab my horse. And I pick them off one by one as My horse makes neighs x 999.

Archers (enemies) who now just back up. They watch me kill everyone… they lost sight of me, and they reset instead of trying find me -_-’ Most BORING AI CHANGE.
Or they pull out melee weapon, and back up… and never swing. Only pop bow back out.

My Horse slowly tilting up or down, So when its on even ground its at 120 angle… Its head in the ground, and back feet floating. -_-’

Pets who want to be in my back side dispite setting distance setting. Who climb into my **** when I try mine on a hill. -_-’

Move to Command, being useless, cause you have spam it several times in a fight to keep my damn Gazzle from getting hit by me. Cause he runs 2 feet to spot I said 10feet away and returns to me like a moron. XD Maybe stay there for 10 seconds…

Load Screens… and the game register that your there… free to hit and abuse. And Often die before your even out of Load Screen.

Never had a problem with this, but yeah, it can be annoying.

Conan exiles isn’t set in the industrial age for a reason, but nevertheless, i’m pretty sure this is false.

Do you play in a PvE-C server? if that so, that’s actually a PvP server without building damage, that’s why.

It’s supposed to be a new feature, but it doesn’t work everytime to me.

You can’t be too safe anywhere, obelisk should be something dangerous to use.

yeah, that’s annoying. Mounting should have its separate button, could be the same used for unmount.

don’t use the bigger workbenches, and stick to the advanced ones. problem solved.

learn to hide better or stay away from danger before using them, they are not meant to be used in combat.
Use potions if you want to heal in the middle of action.

yeah, it’s one of those things that are annoying to use.

Excesive landclaiming, overpowered thralls and the poor weapon balance in the game :^)

They should add the key F to follow, pressing F again to unfollow

1 Like

I just hate there are no beards on my Æsir male thralls and a severe lack of blonde Æsir in general.

1 Like

You can totally craft more than one glass flask in the new casting bench. The trick is you start with 1 and then quickly hit the key/option for all or 10 and it starts crafting more than one.

Hate that I can’t deploy any kind of elevator at all in my base. Will not snap to anything! So my character is getting plenty of cardio whilst she waits for the day she can take her fast elevators out of storage. Also hate that crafted hardened steel cages are invisible in the Exiled Lands.

The “Remove Bracelet” and “Restart Character” buttons are right on top of one another.

I tend to just got on autopilot when I remove bracelet to get back to a spawn point:
Menu Button–> Down → X X (I usually don’t even think about it, because I’ve done it so many times.)

However twice now I have lagged while going into the menu and went down one too many times, hit X X and boom, character deleted ;_ ;

1 Like

Here’s my totally normal and not at all nitpicky and weird list of annoyances with this game:

  • The hair and clothing physics breaking if you make your exile shorter or taller than the default
  • The birds on Siptah being called “pelicans” when they are clearly storks
  • The big cat cubs whining like puppies
  • The baby Komodo dragons just being shrunk-down versions of the adults rather than looking like actual baby monitor lizards
  • The lack of lionesses when in reality they should far outnumber the male lions
  • Are the zebras still in the game? I haven’t seen them since a couple updates ago but they were pretty bad
  • I’m still not super fond of the crocodile design either. Also they don’t swim.
1 Like