Dedicated server problems

Hi there, I’m new to the forums but have been playing Conan for a while. About a year ago I hosted a server and friends and I played the game together until eventually timing just fell out and we stopped playing. This week we had time and I decided to setup a new server so we could start fresh.
I downloaded the dedicated server tool here on the forums (which I also used last time.) I got it setup and my ports all show as green (accompanied by the tool telling me my machine was reachable from outside sources) and I don’t currently have any mods installed. I’m using the multihome feature in order to play on the server using the same machine I’m hosting with.
I am able to join it perfectly fine with no issues. But despite my ports being clearly open (and port forwarding is something I am not a stranger to, I host all the games we play) nobody is able to join. I have tried different ports, different settings and configurations, and validating the server. My friends have also tried validating their caches. I am at a complete loss for what is wrong with the server.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.