Eldario weapons disappear in tralls

most eldario weapons disappear when equipped to a trall. if the team in the main hand or secondary hand hold until the trall places it back in inventory. is it being solved? thanks

at least someone can tell me if it also happens? I do not know if it is a bug or that they are directly prohibited from putting those weapons to the tralls

confirmed, have the same problem

1 Like

This happened to me yesterday. Gave my thrall a Legion Great Sword that I just created using the time consuming to farm eldarium, and POOF! Gone into the yet to be explained abyss. Has anyone had any eldarium weapons that did not disappear in their thralls inventory? If so please let me know and I will try to aquire said weapon.

1 Like

Not personal experience - just something I’ve seen posted - so take that as you wish: Legion weapons (I believe) have the attribute ‘Variable’ (meaning when crafted their damage (maybe other stats) is within a range rather than always being the same - so two of the same weapon might have different damage stats).
Apparently, weapons with the attribute ‘Variable’ are the specific ones that disappear when equipped to thralls.

(I think this was reported as a bug and is being looked at - but I may have seen it in a different category.)

2 Likes

I thought I saw on the wiki that the legion weapons sate your hunger. If this is true it is likely the thralls are eating the weapons. Bug? Maybe? Might be thralls reacting to food normally.

2 Likes

Yes it had the Variable effect. Thanks for the info.

1 Like

I didn’t look to see if it sated me or not, but that would make a lot of sense.

If this is so, it’s the funniest bug ever

Yeah would appear Legion swords get eaten, just tried it out with different Thralls and different weapons, and the Legion one insta gone. Must be like what was said about Variable effect.

Indigestion incoming! That’s going to be a nightmare coming back out.

1 Like

Same situation with Legion sword. Client crash if entering a dungeon with that thrall.