PC Official BUG - Sword of crom is gone from thrall inventory

Game mode: Online official
Type of issue: Bug
Server type: PvE
Region: Americas

Just checked my thrall over by the unnamed city and her sword of crom is gone. Not exactly sure which patch caused it, but she no longer has that weapon. I have been playing on Siptah since it came out and haven’t messed around over at the unnamed city since then and just checked her today to find the sword gone. I went back 21 days in the event log and nothing there about it so not sure what happened.
Anyone else find this sword missing now? was it removed from game?

I pulled up Single Player and noted that the Sword of Crom is still in game.

Hey there , are you sure the sword was on this thrall , or wasn’t in the thralls hand , do you have any clanmate that could have take it out and put elswhere ?

I’m asking cause I went to look at my thralls after your post , they all have their SoC ( at least the ones that i put one on ) PVE-C official !

thanks for checking. It is a mystery to me. No other clan mates, so that is not the reason. I am pretty sure it was back in their inventory after the last time we farmed fragments of power. I tend to remove their weapon from their hands to get them standing normally again. So it should have been there.

Guess I will chock it up to me misplacing it or accidentally dropping it.

Thanks again.

mhm i’ve seen occurence of sword disapearing ( become invisible in the thrall’s hands inventory slot ) but is still considered there , when you try to swap weapons ( particularly with shields and one handed weapons ) from inventory to hand , have you tried to make the thrall fight ?
( he may take out of his hat like a true magician the sword :wink: )

yeah I tried that and put a new sword in each slot to see if it would pop out, but no luck. oh well. I will hopefully get another one. thanks for the help

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.