Fatal Error: Failed to download the latest patcher

Worked perfectly fine just a couple of days ago. Started up yesterday, had this message: “Fatal Error: Failed to download the latest patcher.”

Tried uninstalling and reinstalling through steam. Same error.
Manually deleted Secret World Legends folder in Steam library and reinstalling. Same error.

Repair broken data had no response. Waited for around 30 min.

1 Like

Just tried on my Steam installation and it looked to patch OK. It crashed with a DX11 error when I first tried to run it though :slight_smile: Tried again and it sat for ages loading to Agartha and had to end task it in Task Manager :stuck_out_tongue: Serves me right for reinstalling GeForce “Experience”

Third time lucky, it appears to be running OK, so it’s definitely not a universal steam issue.

If you have redownloaded, it might be worth trying to run PatcherSetup.exe directly as admin, to see if that makes a difference:

That has worked for me in the past. Most often though when I have had this same problem, it has been an underlying problem with my ISP that I couldn’t see. Hard resetting my cable modem (power off and physically disconnecting to force a reset of my IP) has resolved those (rare) issues.

Good luck, I hope you find a way through…

1 Like


I ran swl after the last GeForce update and it was fine so that wasn’t the issue.
Running the patcher as administrator as you suggested resulted in the same ‘fatal error’.

Reset the modem too. Did not work.
Thanks for taking your time to answer though.

Do you have antivirus that may block loading maybe? Try to turn it off or whitelist the app.
Running PatcherSetup directly and as admin was supposed to work though. :thinking:

1 Like

Hi! I turned off the firewall and scans. Same error.

I do wonder if it was due to me trying to start the game on a school network the other day though. Steam couldn’t access the internet as usual, but out of curiosity, I tried starting up swl but it didn’t even load. I’m not familiar with this but perhaps the school network contributed to this error?

Oh, it may be. Your network admins may believe their network is not for games and block certain stuff.

Yes, but I’m on my home’s network now. :joy:

Just tried again. Clicking on the desktop shortcut worked. The patcher actually downloaded files this time and everything worked fine after that.

I think there must have been an update to swl because the blue christmas screen has been replaced with the usual red one.

Thank you Broc and Jess for your help! :grinning: