Struggling with SWL patcher - Error 105 constantly


#1

I’ve been struggling since first installing the game with just getting it to run the patcher and even give me a ‘start game’ button. A friend once suggested that I run the dx setup program in the SWL folder, and that worked, but only once. Ever since then, nothing has worked. The patcher takes a long time to sit there doing nothing until it decides to give me Error code 105.

I have tried clicking the ‘repair broken data’ button also, and that seems to do nothing and/or freezes. One post I read on the forum suggested running the patcher setup exe before trying to patch again… So I tried that, and still the same results. I’ve uninstalled and re-installed the game a few times. I tried installing it directly from the Funcom site, and through Steam. Nothing seems to work.

Any help would be appreciated. For reference, if it matters - I’m on a Dell laptop with Windows 10 factory installed. The game ran excellently the first couple of times that I was able to run it… Just wish I could make it run again!


#2

Hi Faithy, I’m sorry to hear that you’re having trouble with the game patcher. Error 105 generally indicates you’re unable to connect to our server. Please try following the general connectivity advice here:

If these steps don’t help, I recommend submitting an email ticket through funcom.com/help at your earliest convenience. That will allow us to escalate you to a specialist who can take a closer look at your specific setup and connection.


#3

I did forget to mention that I turned off my firewall as I saw that mentioned somewhere before, but I will make sure antivirus and everything is off as well and retry again this evening (heading home from work in about an hour) and will update once I give that a shot… Thanks for the advice, I hope it helps.


#4

Quick update; I did disable my anti-virus (all I have is what’s built into Windows 10) before trying again, and it is finally actually patching now without any problems. It’s taking a very long time, but it may work. I’ll post another update once I get a chance to actually play the game, and do a reboot, and try again to make the game run (with and without antivirus on) just to make sure whether that was the issue all along…


#5

The game worked briefly. I went AFK and the screen saver came on causing the game to crash apparently. After which I haven’t been able to get it to start, again. Same issue. No idea what to do. I’m getting really disheartened and close to giving up on ever playing SWL again. :frowning:


#6

I’m sorry to hear that. I understand this type of problem can be very frustrating to work with. Since you’ve already tried the advice from the linked thread, you should next submit an email support ticket through funcom.com/help - we can then escalate you to a technical support specialist, who can take a closer look at what’s going on.


#7

I will give it a try, thank you.


#8

Same problem here. ‘Fun’ fact in this problem is ‘launcher’ do nothing in this game till some patch release and you type username/password in game client. If only there is a way to run game client w/o that ‘launcher’. Anything releated to vnp/proxy/router is not working. Direct connection with external IP works like magic. Well… sadface.


#9

We’ll be happy to forward your feedback for future consideration, but in the meantime we can help you troubleshoot further over email ticket. Please go to funcom.com/help and submit a tech ticket so we can work with you on resolving this.


#10

I wanted to share an update after going back and forth for a couple of weeks with Funcom customer service through email. They checked a couple of things and suggested that I try running the game with a VPN. I don’t have the ability to do that, so I was at a dead end.

However, I recently made a new friend who has worked with software for many years, and I let him use TeamViewer to try and figure out what was going on. What we determined to be the problem was something that Funcom could not have anticipated. I have a program installed on my computer that reads and transmits data, and I am compensated for that data. The problem was, this program was messing with my network settings, setting up a proxy automatically and causing the issue where the game would not run. Now, if I disable this program completely before running the patcher, I have no problems at all and can run the game just fine. I do not know how many people in the future may run into these problems, but if you’re like me (constantly strapped for cash) and willing to let some program run on your computer to submit data to some 3rd party that pays you for it… this may be your problem, too. Disable whatever processes are running from that program and try again.

Many thanks to any who took the time to read my post(s) and offer suggestions. Just glad this was finally solved and I’m actually able to play SWL at last! I hope this information helps someone else in the future, now that it’s figured out.


#11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.