Fatal Error when i equip or unequip any kind of armor

Basic Info:

Platform: Steam
Issue Type: Crash
Game Mode: Online Private
Server Type: PvP
Map: Custom (please specify)
Server Name: LYSRP
Mods: There is 52 mods, i can send the workshop link in DM.


Bug Description:

I’m the only player in the server who got a fatal error when i equip an armor through the inventory, other players doesn’t have any problems and the admins don’t know what to do in order to help fixing the problem.


Bug Reproduction:

I equip any armor piece from any vanilla or modded armor.

1 Like

Almost impossible to say without knowing how all the mods you are using work together, but its clearly a mod. The only way to know which one is to add them one by one in single player until you find the offender, and that doesnt even rule out a mod conflict… which leaves the option of a “bubble sort” of a kind… remove half, see if it crashes, if not, remove the other half and add the prior half until you whittle it down to the offending mod/mods. The hazard of using so many mods I’m afraid…

Hey, thanks for the reply, i don’t have any problem in solo even when i use all the modlist at the same time, the problem occur only when i am on the public server.

You can find the modlist here.

Pippi.pak
ModAdmin.pak
ModControlPanel.pak
TotAdmin.pak
TotChat.pask
BarbarianBarber.pak
Immersivearmor.pak
EvilsCabinet.pak
RAFantasy.pak
HighHeels.pak
HighmanesArsenal.pak
Lotsu_Roleplay_Additions.pak
Weapons.pak
Grim_Wonderbody_reupload.pak
GrimProductions.pak
Warrior_mutator_mod.pak
ExilesExtreme.pak
Beyond_Decor.pak
Beyond_DecorII.pak
Beyond_Stations.pak
ShimasCompendium.pak
Shanis-Stuff.pak
Lotus-Decor.pak
Lotus_Variety_Mod.pak
AmunetDecoCollector.pak
TestingRaceMod.pak
Savage_Wilds.pak
LCDA_bestiary.pak
Emberlight.pak
DungeonMasterTools.pak
Devious_Desires.pak
RavencrestCouriers.pak
BetterThralls.pak
TheColdEmbrace-Main.pak
NorthernTimber.pak
SandAndStone.pak
CreatureComforts.pak
Dudes_Creative_Constructions.pak
SvS3.pak
SvS_Extended.pak
matswapper.pak
Pythagoras_Support_Beams.pak
LBPR_Collision_Update_Add_On.pak
UnlockableContainers.pak
RoleplayRedux.pak
No_Building_Placement_Restrictions.pak
StacksizePlus.pak
LCDA_gameplay.pak
UIMod_Hosav.pak
NoUIPopup_DecorsandBenches.pak
STFU.pak
TotCustom.pak

I’m not sure from looking at your list but the problem is probably a mod affecting whats called the “paperdoll” (the character portrait in yoir inventory. Just a wild guess not having ever used the mod, but the one called testingracemod… are you a race that no one else has chosen on the same server? There are several others that I’ve never used, but when you tested in singleplayer, did you use the same configuration for your character? Just spitballing.

I would ask the provider/admin of this server.
They should know about mod conflicts.
Did you install the mods in the same order as they are on the server (autoinstall)?

Thanks you both for your quick reply, i have installed every mods in the same order and i will ask the admins about the character portrait in the inventory.

Indeed, when i was alone i haven’t choose any race but i am human so it shouldn’t be a problem however i am the only one with the berserker class.

Don’t get me wrong; I was just making a guess based on the one’s that I’m unfamiliar with. If everyone has the same mods, then it’s stuff like that to look for. Something you could be doing different than everyone else, maybe hardware differences (like if your ram is maxed out… one mod certainly can’t account for what all the mods together would use). Single player is always a good place to start, but it is true that some mod errors only occur on a server and vice versa.

There may be a difference between choosing nothing and choosing human to be honest… if the mod flags certain things as belonging to “human” it still could be the issue. The mod probably just assigns some kind of variable called “race” and if you pick “human” it may have certain things that try to execute that aren’t working correctly because let’s face it… how many people use a mod to use different races and still pick human :rofl:

Ok i have found the solution, the problem occur only when i take the berserker or paladin class on the server.

Thanks for your help.

Glad you found a solution. It would probably be a good idea if the mod author has a discord to go to their discord page and let them know using whatever bug reporting process they have set up.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.