(Fixed, kinda?) Game tries to install Direct X and wont launch even though direct X is already on the computer

Got it installed on steam and when I tried to launch it it started a first play installation which this time meant getting direct X which is already on the computer. What to do? It won’t launch cause it thinks I don’t have direct X and it won’t install cause I already have it.

So I get the error message:

The following component(s) are required to run this program:

DirectX Runtime

I’ve tried several times to install Direct X from microsofts website and the installation fails and refers me to go to DirectX.logs where it says the failure is due to that all files are already there so there is nothing else to update.

Update: I got it to work. What I did was that I installed Hellblade Senuas Sacrifice on my computer who also runs with Direct X runtime, the difference being that the installation launched properly for me as opposed to with this game. I can play the game now but I think the problem is worth looking into unless we want “buy Hellblade” to be the only solution available.