Game does not save inversion setting


#1

Game mode: Singleplayer
Problem: Bug
Crash dump link: N/A

The game does not save mouse inversion settings.


Repro steps:

  1. Launch the game and enter a singleplayer session.
  2. Open the Settings menu, go to Controls, click the “Invert Y” checkbox.
  3. Apply settings and return to the game.
  4. Hit Escape, select Quit Game, and confirm the exit.
  5. Relaunch the game and enter a singleplayer session.

At this time, the inversion settings will be lost. Additionally, any changes to sensitivity will also be lost.


#2

Mines the opposite, every time I log in I have to turn inversion off.


#3

OK, so I just discovered something interesting, it looks like this happens only if you follow the repro steps above. That is, you must choose Quit Game. On a hunch I tried the Exit to Main Menu, then closed the game, and when I restarted it again later the inversion setting had indeed been saved.


#4

I’ll give that a try, that may be how I accidentally got it stuck on inverted.


#5