Game freezes on exit to main menu

Game mode: [Singleplayer/Coop]
Problem: [Crash | Bug ]
Region: [Oklahoma]

[ First off I apologize if I did this incorrectly I am new to the whole reporting bugs thing. I did notice another topic on this bug but it had closed automatically after seven days and I could not reply to it. Anyways I play on Xbox One X with my friends in Single Player Coop I host the game. We received the update adding elephants as tames yesterday and had been playing all night. My friend logged off and I pla
yed for a bit longer. Finally was ready to stop and went to exit the game. Upon hitting exit to main menu it showed the disconnecting and then showed the progress bar at the bottom that
Normally finishes without any delay. This time however it froze with the progress bar full and did not finish exiting the game. I had to hit the home button and close the game that way which made me lose at least an hour and half work. For whatever reason it hadn’t autosave in the time since my friend signed out. I have since then played more to see if the problem would persist It indeed has. No matter how long or how little I play it may or may not exit correctly. I have had it exit without incident and times where it froze and did not save. Others where it did not exit correctly but at least managed to autosave and only lose a little bit of progress. I also tried turning off the purge meter because I thought it may have had something to do with that because I had not turned it on before. It however did not change anything it still froze upon exiting. By the way I was either capturing and taming thralls or taming animals in the animal pen’s when exiting. I had just finished putting thralls in the wheel of pain the first time I quit and had the bug. The other times I had just placed down greater animals that I had just tamed. And then tried to exit and same thing happened but did not lose as much progress because autosave did work. Out of about ten times of exiting game trying to find a workaround or at least get a better idea of the glitch it only properly existed twice the other eight were freezes on exit. Edit Seems to have been resolved by deleting the save data. Apparently it was corrupted after update in case anyone else has similar issue. I will update if it happens again.]

Steps on how to reproduce issue:

  1. Go into Single Player Coop
  2. Play the game for a bit
  3. Try to exit to main menu
  4. Loading screen freezes and doesnt save

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.