Single player not saving & laggy / freezing

Game mode: [Single-player]
Type of issue: Crash, Bug, and Performance
Server type: PvE
Region: Single-player- USA
Hardware: Xbox One X


Bug Description:

After the initial start of a new character, every thing seems okay. Exiting to main menu takes a minute or two. Eventually, the game becomes laggy, freezing for two or three seconds randomly with several seconds in between - and can happen multiple times in the span of a minute. Exiting through the select button to the main menu takes a few minutes, several sometimes- frozen on “Disconnecting”, sometimes goes back to the main menu, sometimes goes straight to Xbox dashboard. Progress is not saved. This was happening on a fresh install. I have not changed profiles (As I have heard some people reporting having this issue have been doing), and have deleted the saves through the manage game on my xbox - nothing has worked. After a certain point, be it one hour or several, eventually single player offline will stop saving. I am currently reinstalling to see if maybe the inital install was a bad one? We shall see.

EDIT: Fresh install, single player offline started freezing for a second or two right at the start. And hour or so in: got killed and frozen on respawn screen. Bed selected, “respawning in:0” frozen. Screen still rotates in the background. Waited. After four minutes, I finally respawned- no loading screen. I used the menu to exit to main menu and after waiting for another few minutes made it to the main menu. Loaded the game- no progress lost this time, but the freezing and lagging contines.


Steps to Reproduce:

  1. Play single player offline. One hour, or five
  2. Eventually the game will become laggy and freezing. Exiting back to the main menu can take several minutes. Sometimes takes you to the main menu, sometimes to Xbox dashboard.
  3. Eventually any progress or changes made to the game will not take affect (Building, thralls, pets etc etc)

Update: Offline Single Player continues to be laggy and freezes after resets, restarts and reinstalls. After playing any amount of time, eventually, going through the menu to exit it will freeze for several minutes, eventually black screen to Xbox dashboard, and progress is lost.

Exited through the menu and after five minutes of a frozen “disconnecting”, it dashboard to Xbox and hours of progress lost.

Greetings,

Thank you for reaching out to us. Could you share some additional information, please?

  • Do you have your game installed on an SSD or HDD?
  • Is the console stable playing other demanding games?
  • Does it exhibit any signs of overheating while playing CE?

In the meantime, we can suggest some steps to assist in this situation. Please ensure that your save is stored on the XBOX cloud before trying each of the following steps and letting us know if they help:

Reset the console cache by holding the power button for about 10 seconds until the console powers off, then disconnecting it from the power outlet for a couple of minutes, then try loading into your SP session. Try to perform a soft factory reset while keeping games and apps.

If the above procedures don’t help, please try to perform a full reinstall of the game.

We hope to hear back from you.

1 Like

It is installed on a HDD.

I don’t have any issues playing any other demanding games. (Ark, No Man’s Sky)

No signs of overheating- crash on exit and lost progress can happen after only a few minutes of playing.

I have cleared the cache, but I will do it again. I have had this issue on a fresh install and have reinstalled twice so far (thank goodness for good internet).

I will try a soft factory reset and see how it goes.

1 Like

I cleared the cache and did a soft factory reset (keeping games and apps) and encountered the freeze on exit. After five minutes it finally went back to main menu- upon loading the save: no progress lost. However, after playing for another 30 mins or so, I died and froze on respawing screen. It dashboarded and fifteen minutes or so of progress was lost.

The freezing on respawn and freezing on exit that leads to dashboard and loss of progress seems to be happening far more often when the game is running for more than twenty minutes or so. - After loading back in I played for five minutes and build a staircase and exited without an issue. But playing for almost an hour, I encountered the freeze on respawn.

Again, my Xbox is not overheating, it seems if the game session itself is longer than twentyish minutes at a time, more than likely it will freeze on exit/respawn and likely crash.

Played for just over an hour and it froze on exit for nine minutes before finally going to the main menu. No lost progress (seems to only happen when it dashboards. Immediately exited again and it only took a few seconds to get to main menu. Seems the longer sessions get it to freeze on exit/respawn.

Greetings,

Thank you for performing the suggested tests.

Is your console on a wired or wireless connection? Would you be able to try putting it on a wired connection to test it?

Before the issue started:
When you finished your play session, did you usually close the game through the main menu?

1 Like

This post was flagged by the community and is temporarily hidden.

I use a wired connection: over 300 Mbps.

I got CE a while ago. When I redownloaded it (just over a week ago) the problem existed. Last night I played for an hour. It froze on exit, dashboarded and twenty minutes of progress was lost.

Even the menu in game takes a second or two to show up sometimes. But the delay is gone after I’ve opened it, at least for a little bit.

I always exit through the menu (select button).

Okay, so after playing for an hour and a half, I tried something.

The last thing I did was build a platform of foundations, and put down an animal pen and wheel of pain. I also put down an inventory chest in front of me and just stood there in game for six minutes before exiting.

The game froze on “disconnecting from game” for ten minutes before dashboarding. Upon load there are some weird things. The platform with the animal pen and wheel are still there (I did that very last), but inventories (my inventory and storage boxes and crafting stations) have reverted to a previous state / save.

Greetings,

Thank you for the additional tests. We didn’t have any updates on Xbox recently that could affect you as described. Have you changed your Internet service provider or its hardware before this situation started?

Can you try fully resetting your router by turning it off and unplugging it for about 10 minutes?

1 Like

I have restarted my internet modem, that has not helped.

The issue with there being no Xbox updates “recently” or other changes like my internet is that I have not played CE single player “recently”. I might have bought it years ago, I didn’t play single player then. Just over a week ago I downloaded CE and started playing again. The freezing on exit/respawn, the crashing and loss of progress/auto saving and saving not working is my whole experience: There was not a time that I played CE single player and it not have these problems.

1 Like

We understand. Thank you for providing all the information requested.

We’ll forward your case to our team for further investigation. We might reach out to you via direct message if there’s anything else they need.

Apologies for the inconvenience, and thank you for your patience.

1 Like

Thank you. And thanks for your help, this has been a brain scratcher for sure.

1 Like

So I’ve done some more testing and figured out how to exactly replicate the freezing and crashing on exit/respawn.

It’s the size of my base. Roughly 800 “Owned Building Pieces”, foundations, walls, ceilings, etc etc, will make it freeze and crash. About 400 and there’s no freezing and crashing. (So far)

And so far, the amount of items in storage containers doesn’t affect anything. I filled flirty or more large chests with stacks of random items (along with crafting stations) and it exited fine.

“Owned Placable Items” might have a connection, but I’ve reached 126 (along with the 400 building pieces base) with no issue.

1 Like