Game Freezes when loading into a saved game with CO-OP activated

Cant play in coop because the game freezes just after loading the world, i can still play in this world in solo game but it is impossible to coop.
Steps to Reproduce:

  1. Start a new game, any difficulty.
  2. Exit to main menu
  3. Continue game with CO-OP activated
  4. Game will freeze when world and character first show up on screen 99% of the time and the other 1% will be during the loading splash screen.

Having this same issue. Played the game on the 12th with a friend, now can’t get back into game. Had this problem before about a year ago (same computer system). Not using any mods this time. It was suggested that I make sure the Saved folder wasn’t set to read only. I don’t know if that’s what fixed it last time (I can’t remember what fixed it, actually.) I have recently uninstalled and reinstalled the game, so things were set back to default, so whatever I did to fix it before has been lost. I did attempt to fix it this time by unchecking the read only on the Saved folder. There was no change.

link to previous issue: Game Freezes when Continuing a Single Player or Co-op game

Update: Sept 20, 2022 - I was hosting the co-op game when this problem began. So I had my friend relaunch his solo game and he had no problems. So then I had him make a new co-op game and I connected to it fine. Then I logged out, had him log out and back in…and it froze just like mine. We’re now uninstalling the game. Too much hastle.