Golems/magic upgrade

Platform: Xbox Series X
Issue Type: Gameplay
Game Mode: Online Private
Server Type: PvP
Map: Exiled Lands
Server Name: Derketo’s Delight

Bug Description:

Since magic was released I have been unable to upgrade the magic from the first tier. Golems will also not craft. The button in both the golem assembly station and thaumaturgy bench do not appear to work even if all required ingerdients / parts are in place. I have watched many tutorials and asked streamers who have shown me live and am just unable to get this to work on my side. I have fresh installed several times, cleared cache and save data all with no effect.

1 Like

Welcome to the Forum
Be aware if you are overencumbered you can’t craft a Golum. @alex21equinox

1 Like

Ahhhhh well that could very easily be why!! I use beast of burden all of the time. I will give it a try shortly. I’m kick myself if it is that cause it didn’t even occur to me. Thank you :slight_smile:

1 Like

No problem at all read it here on the Forum after I ran into the situation. Overencumbered prevents the moving around ritual part
Good luck.

You are amazing, solved both issues, thank you!!!

1 Like

Thank you. It is what happens when you spend more time on the Forum than playing the game lately…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.