Harbor of The Drowned- Bugged

Basic Info:

Platform: Steam
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvE
Map: Isle of Siptah
Server Name: 6111
Mods: None

Bug Description:

Harbor of the Drowned is bugged. doors inside the vault have been both partially stuck open, or they will not open at all. The boss glitched after i killed him and his body vanished so i couldnt loot anything from it. it respawned a few minutes later forcing me to kill it again before it would let me open to gate to get out. Upon getting into the last room after the boss the big loot chest was totally glitched out with zero loot showing. i tried to open and reopen several times. i even tried opening closing my open inventory and thralls inventory then going back to the loot chest hoping something would trigger it to fix… Sadly nothing did so i had to leave without any loot.

Bug Reproduction:

just doing the usual things in the vault… nothing usual at all.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.