HELP - It takes too much time to actually get in to play

Extremely Frustrated with the amount of time it takes to load? the game. When I first log into my account on Offical servers its extremely quick, however there are trees in my house, and none of the doors or crafting stations “load”. Over the span of the next 10-30mins pieces of the house start to spawn in. If im lucky and one of the doors leading outside spawn I can at least get outside, however I still cant interact with anything. Resources are there but I cant touch them as they are ghosts…
What have I done? Well I have installed the game, I have resinstalled windows and reinstalled the game, I have ensured I have used updated drivers for everything (there were a few that were out of date before). I have also tried it on 2 different systems on 2 different networks… The issue continues…This also happens when I die btw, though if a clan mate is on and they interact with a door i can then see that door, the rest stays ghosted until an unknown amount of time…maybe its me mashing my head on keyboard…no idea really…
2 systems I have tried it on
Intel i5-7300 16gig ram 512 ssd 1050ti Graphics
Intel i9-9900 32gig ram 2tb NVMe 3080 graphics

Any suggestions?

1 Like

Server number and region also @Community since its an official as they can help and info I asked will make it easier to help you

Offical 1942

Every place able asset loaded on EL servers seem to take ages… (except for building pieces)

On Siptah the trees, stones etc. stay visible even when buildings are on top.
Can’t cut them down, they give nothing but you can’t move through them*

*I didn’t restart to game if the issue remains though…

How many placeables and how big is the base?

I just recently started playing a bit with an old character I had on EU pve-c1041 and I experience the exact same thing, buildings load in right away, but all placeables load insanely slow like you experience… it can be anything from 10 minute and up to half an hour.
I have a very fast internet connection, really good gaming pc(i9 9900k, 32 gb ram, rtx2080TI, ssd) and other official servers I play on load everything within a couple of seconds, even huge bases, but on this particular server I don’t even have a big base since I just started a few days ago…

I think the problem lies elsewhere, I do not believe for a second that it has anything to do with having a big base, slower internet connection or anything else user related, but most likely something with the server itself that cause this weird behavior :slight_smile:

I think @Halk have had some similar problems, maybe he has something to add to this problem that is very real for some on specific servers :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.