Helpfull modules for bebot, available to all ingame

Hey all!
I have updated a couple of modules for bebot and made them public in my own bot. This means that everyone can send a tell to Isendyourcmd to use them even if you are not a member of the bot.
Isendyourcmd is the name of my bot and should be online 24/7.

Bound module
I have updated the old !bound module to have all raids available aswell as RF main quest CD.
Use ingame send:
/tell Isendyourcmd !bound

If you are a bebot owner add this in the “bebot folder/custom/modules”.
If you already have the old one you need to delete the database info for bound.

Recipes module
I found a module for recipes for AO on the bebot forum that I modified to work for AoC.
Use ingame send:
/tell Isendyourcmd !recipe
/tell Isendyourcmd !recipe trade
to see all currently added.

If you are a bebot owner add this in the “bebot folder/custom/modules”.

TimerAA module.
Link PHP 5.x:
Link PHP 7:
Use ingame:
/tell Isendyourcmd !help timeraa

If you are a bebot owner add this in the “bebot folder/custom/modules”.

Update: 06.05.2019
MeatHooks have updated the old !items module and created a NEW Central Items DB! woop :smiley:
How to use it:
You can also use it now by doing this ingame:
/tell Isendyourcmd !items < drag & drop item or items here >
/tell Isendyourcmd !items < name of item >

If you want this to be run in your guild bot, send a message to @MeatHooks and he will help you set it up!

Hope someone find it usefull :smile:

1 Like

Changelog for !recipe module:
28.04 Added base culture recipes.
28.04 Added culture weapons.
28.04 Added a list of all uncut gems.
01.05 Added Weaponsmith profession costs.

Thanks! The recipe module is indispensable. Is there a way to contribute to it, so that any player can add locations for ingredients or recipies?

I am not sure how I can make it easy to share and editable to others. If you want to contribute, I think you need to download the file, open in a text edit program (I use notepad and notepad++), edit/add new entries and maybe share it here.

I am using my own collected recipes and this:

Get the items database module working :stuck_out_tongue_closed_eyes:

I would love to get that working again! I am just not sure how to make the backend code to add all the items to a database.
I do have a domain I could use for it, only need to get a working database and the code for it to work.

Would like help on that though.

I have also been thinking of resurrecting the Items module and database as of late.

I will take a look at the code again and see what I can come up with.

I will update back here in a few days and let you know what I figure out.

Awesome! Thanks alot! :smiley:

Ok, I think I am at the point where I can open up the new code to a couple outside guilds running BeBot that would like to test the new Central Items DB. :smiley:

Send me a private message here with the name of your guild bot and I will select a couple to start testing and send them back instructions for downloading the files, usage and the required passkey.

Once it is tested out well for a week or so, we can open it up for more people to use.



If anyone wants to add items to the new Central Items DB you can use this command:
/tell Isendyourcmd !items then at the end drag and drop the item you want to submit.
Remember you need to be friends with the bot first, use this: /friend Isendyourcmd

added timerAA to my bot, and it seems to forget what they added after relogging.
Is this the module, or something else?

Hey. It could be. What version do you have?

I updated it recently and Im still working on it.
When doing !timeraa set done it does save it but will reply upon logon still.

Edit: Fixed it on my end. Please redownload the last version: 1.0.7 and see if its working.

1 Like

I try to add them to my own bebot and it just crashes the whole thing. I am adding them under the custom modules folder, but to be honest I’m not entire sure what else I would be doing wrong. Is there another step I’m missing?
Edit: Bound now works, but trying to load Recipes still crashes the bot. “Fatal error: Call-time pass-by-reference has been removed in… on line 27.”

What is the error message saying?

Hi, I am trying to use the TimerAA.php but the initial error I keep getting is: Uncaught Error: Call to undefined function mysql_real_escape_string()
I tried searching and it was because my PHP version is 7.3. Thus I had to change the small part because of depreciation: mysql_real_escape_string() to mysqli_real_escape_string(). Now, whenever I try to utilize the command the command !timeraa set 39. I get a response saying “is not a number”. How can I fix this?

Sorry for late reply!

I updated the file on my end ran it in on my bot with PHP version 7.2.33 - all worked fine.
See if this works for you.