Invisible enemies/animals PS4/PS5

Basic Info:

Platform: PlayStation 4
Issue Type: Gameplay
Game Mode: Online Private
Server Type: PvE
Map: Exiled Lands
Server Name: Conan the Librarian

Bug Description:

All elephants, some rhinos, and a lot of other enemies and bosses throughout the entire map are invisible. All we can see are the enemies eyeballs or sometimes nothing at all. Issue persists on my PS4 pro as well as my friend’s PS5. Switching to performance mode makes no difference.

Bug Reproduction:

Has been happening since we started our server on July 17th 2023.

1 Like

I’m a new player to Exiles on PlayStation. I’m playing on a PS5. I’m adding the following info about invisible “greater” beasts/monsters/bosses. I raised a greater shaleback who is invisible while in the desert but suddenly becomes visible while in the Jungle.

I have also encountered an invisible rhino near Sepermeru; incredibly difficult to fight because you can’t see it coming.

1 Like

Just wait until you meet Thunderfoot, a world boss invisible elephant.
Use R3 while roaming around to spot the health bars.


Good tip, thanks! Hopefully they can fix this issue. My friends and I did a full play through of Exiled Lands and Siptah a year ago and the game ran flawlessly on my PS4 with none of these issues.


Exactly. That’s all we want, a functional game, @Goodbin .


Unfortunately you will probably come across more invisible enemies in your travels. Sounds like these problems all started after Age of Sorcery came out. Keeping my fingers crossed that they haven’t given up on their console community :crossed_fingers:

1 Like

Also having the same issues. Can’t see any elephants or rhinos or yetis. Some world bosses just have eyeballs and it’s horrifying lol. Please fix this. It’s been going on for far too long. We just want to see how we’re getting our thick hide. We have lots of tigers fighting nothing.


Question: Are they invisible only in the exiled lands or on the Isles of Siptah as well?

It’s been happening way before age of sorcery as far as I can tell I have made a report about it as well but nothing seems to every get solved like I made a report about a journey step being missing as well and still no fix

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.